POJ3276-젖소 뒤집기

제목.
Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.
Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same location as before, but ends up facing the opposite direction. A cow that starts out facing forward will be turned backward by the machine and vice-versa.
Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.
Input
Line 1: A single integer: N Lines 2..N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.
Output
Line 1: Two space-separated integers: K and M
Sample Input
7 B B F B F B B
Sample Output
3 3
Hint
For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)
제목의 의미
사실은 너에게 n마리의 젖소를 주는 것이다. 그들의 방향은 뒤쪽과 이전이다. 지금 너는 이 젖소들을 뒤집을 수 있다. 매번 K개를 연속으로 뒤집어야 한다. 지금 K를 찾으면 뒤집는 횟수가 가장 적고 모든 젖소가 앞쪽을 향할 수 있다.
사고의 방향
우리는 자취법을 채택하여 이 문제를 풀 수 있지만, 사실은 동태 기획으로도 이해할 수 있다.길이가 K인 자는 이 구간의 총 회전 횟수를 유지한다.우리는 먼저 초기 젖소의 상태를 기록한다. 0은 앞으로, 1은 뒤로 한다.1부터 n까지 k를 매거하기 시작하며 초기 회전 횟수는 0입니다.그리고 우리는 젖소의 초기 상태와 자 구간 내의 총 회전 횟수에 따라 현재 위치가 이미 앞을 향해 있는지 판단한다.앞을 향하지 않으면 현재 위치가 한 번 뒤집히고 이 위치가 뒤집힌 것을 기록합니다.그리고 현재 확장된 길이가 자의 최대 길이에 도달했는지 판단한다. 만약에 첫 번째 공헌을 없애야 한다. 왜냐하면 우리는 다음에 하나를 앞뒤로 확장해야 하고 첫 번째 공헌은 자의 최대 길이의 다음 위치에 영향을 주지 않기 때문이다.매번 뒤집을 때마다 반드시 k위를 뒤집어야 하기 때문에 마지막 k-1위에 대해서는 뒤집을 수 없다. 이전의 공헌이 이 젖소들을 앞으로 향하게 할 수 있는지 판단하고 k가 합법적인지 판단할 수 밖에 없다.
코드
package com.special.POJ;

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.PrintWriter;
import java.util.Arrays;
import java.util.StringTokenizer;

/**
 * POJ3276
 *    
 *        K       
 * Created by Special on 2018/4/21 23:53
 */
public class POJ3276 {

    public static void main(String[] args){
        FastScanner input = new FastScanner();
        PrintWriter out = new PrintWriter(System.out);
        int n = input.nextInt();
        int[] dir = new int[n];
        int[] flag = new int[n];
        for(int i = 0; i < n; i++){
            dir[i] = (input.next().equals("F")) ? 0 : 1;//        
        }
        int ansK = Integer.MAX_VALUE, ansN = Integer.MAX_VALUE;
        for(int k = 1; k <= n; k++){
            int sum = 0;
            int cnt = 0;
            Arrays.fill(flag, 0);
            for(int i = 0; i <= n - k; i++){
                if(((dir[i] + sum) & 1) == 1){ //                  
                    flag[i] = 1;
                    sum++;
                    cnt++;
                }
                if(i - k + 1 >= 0){//         K,            
                    sum -= flag[i - k + 1];
                }
            }
            // n - k + 1   n  ,      k,      ,        
            for(int i = n - k + 1; i < n; i++){
                if(((dir[i] + sum) & 1) == 1){ //      ,          
                    cnt = -1;
                    break;
                }
                if(i - k + 1 >= 0) {sum -= flag[i - k + 1];}
            }
            if(~cnt != 0 && cnt < ansN){
                ansN = cnt;
                ansK = k;
            }
        }
        out.println(ansK + " " + ansN);
        out.close();
    }
    //  IO
    static class FastScanner {
        BufferedReader br;
        StringTokenizer st;

        public FastScanner() {
            try {
                br = new BufferedReader(new InputStreamReader(System.in));
                st = new StringTokenizer(br.readLine());
            } catch (Exception e){e.printStackTrace();}
        }

        public String next() {
            if (st.hasMoreTokens()) return st.nextToken();
            try {st = new StringTokenizer(br.readLine());}
            catch (Exception e) {e.printStackTrace();}
            return st.nextToken();
        }

        public int nextInt() {return Integer.parseInt(next());}

        public long nextLong() {return Long.parseLong(next());}

        public double nextDouble() {return Double.parseDouble(next());}

        public String nextLine() {
            String line = "";
            if(st.hasMoreTokens()) line = st.nextToken();
            else try {return br.readLine();}catch(IOException e){e.printStackTrace();}
            while(st.hasMoreTokens()) line += " "+st.nextToken();
            return line;
        }
    }
}

참고 자료
  • https://blog.csdn.net/qq_34374664/article/details/53028870
  • 좋은 웹페이지 즐겨찾기