Inter-AS mVPN Option A Pattern-1 : 각 AS 간의 멀티 캐스트에 SSM 사용
우선
이 검증 내용은 2011년에 MPLS VPN에 대해 실험실에서 확인한 결과를 로컬 위키 서버에 저장했습니다. 그 후, 누군가의 참고가 되었는지 어떨지는 모릅니다만, 이제 wiki 서버도 움직이고 있지 않기 때문에, 아무도 이 내용을 보는 것도 없다고 생각합니다. 그렇지만, 최근이 되어 스스로도 재검토하는 일이 있었으므로, 조금이라도 참고가 된다고 생각해, 이쪽에 올리기로 했습니다.
Topology
그림-1
그림-2
config
R1
confighostname PE3A
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast-routing vrf green
!
mpls label range 1000 1999
mpls label protocol ldp
!
interface Loopback0
ip address 10.1.1.3 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 192.168.143.3 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip vrf forwarding blue
ip address 172.20.34.3 255.255.255.0
ip pim sparse-dense-mode
mpls ip
!
interface Ethernet2/0
ip vrf forwarding green
ip address 172.23.35.3 255.255.255.0
ip pim sparse-dense-mode
mpls ip
!
router isis
net 49.0000.0000.3333.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 1 metric 1
network 172.23.0.0
no auto-summary
version 2
exit-address-family
!
address-family ipv4 vrf blue
redistribute bgp 1 metric 1
network 172.20.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
bgp redistribute-internal
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
bgp redistribute-internal
redistribute rip
exit-address-family
!
address-family ipv4 vrf green
no synchronization
bgp redistribute-internal
redistribute rip
exit-address-family
!
ip pim ssm default
!
R2
confighostname PE3B
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast-routing vrf green
!
mpls label range 2000 2999
mpls label protocol ldp
!
interface Loopback0
ip address 10.2.2.3 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.16.43.3 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip vrf forwarding blue
ip address 172.20.34.4 255.255.255.0
ip pim sparse-dense-mode
mpls ip
!
interface Ethernet2/0
ip vrf forwarding green
ip address 172.23.35.4 255.255.255.0
ip pim sparse-dense-mode
!
router isis
net 49.0000.0000.3333.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 2 metric 1
network 172.23.0.0
no auto-summary
version 2
exit-address-family
!
address-family ipv4 vrf blue
redistribute bgp 2 metric 1
network 172.20.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
redistribute rip metric 1
neighbor 10.2.2.1 remote-as 2
neighbor 10.2.2.1 update-source Loopback0
neighbor 10.2.2.2 remote-as 2
neighbor 10.2.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
redistribute rip
exit-address-family
!
address-family ipv4 vrf green
no synchronization
redistribute rip
exit-address-family
!
ip pim ssm default
!
R3
confighostname P1A
!
ip multicast-routing
!
mpls label range 3000 3999
mpls label protocol ldp
!
interface Ethernet0/0
ip address 192.168.143.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip address 172.19.142.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet2/0
ip address 172.30.41.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
router isis
net 49.0000.0000.4444.00
!
R4
confighostname P1B
!
ip multicast-routing
!
mpls label range 4000 4999
!
interface Ethernet0/0
ip address 172.16.43.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip address 172.19.42.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet2/0
ip address 172.30.141.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
router isis
net 49.0000.0000.4444.00
!
R5
confighostname PE2A
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
!
mpls label range 5000 5999
mpls label protocol ldp
!
interface Loopback0
ip address 10.1.1.2 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.19.142.2 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding blue
ip address 172.17.12.2 255.255.255.0
ip pim sparse-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.2222.00
!
router rip
version 2
!
address-family ipv4 vrf blue
redistribute bgp 1 metric 1
network 172.17.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.1.1.3 remote-as 1
neighbor 10.1.1.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
redistribute rip metric 1
exit-address-family
!
ip pim ssm default
ip pim vrf blue bsr-candidate Serial1/0 0
ip pim vrf blue rp-candidate Serial1/0 group-list 1
!
access-list 1 permit 239.1.1.1
!
R6
confighostname PE2B
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
!
mpls label range 6000 6999
mpls label protocol ldp
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.19.42.2 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding blue
ip address 172.18.22.2 255.255.255.0
ip pim sparse-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.2222.00
!
router rip
!
address-family ipv4 vrf blue
redistribute bgp 2 metric 1
network 172.18.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 10.2.2.1 remote-as 2
neighbor 10.2.2.1 update-source Loopback0
neighbor 10.2.2.3 remote-as 2
neighbor 10.2.2.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
redistribute rip metric 1
exit-address-family
!
ip pim ssm default
ip pim vrf blue bsr-candidate Serial1/0 0
ip pim vrf blue rp-candidate Serial1/0 group-list 1
!
access-list 1 permit 239.2.2.2
!
R7
confighostname PE1A
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf green
!
mpls label range 7000 7999
mpls label protocol ldp
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.30.41.1 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding green
ip address 172.25.11.1 255.255.255.0
ip pim dense-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.1111.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 1 metric 1
network 172.25.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback0
neighbor 10.1.1.3 remote-as 1
neighbor 10.1.1.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 vrf green
no synchronization
redistribute rip
exit-address-family
!
ip pim ssm default
!
R8
confighostname PE1B
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf green
!
mpls label range 8000 8999
mpls label protocol ldp
!
interface Loopback0
ip address 10.2.2.1 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.30.141.1 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding green
ip address 172.25.111.1 255.255.255.0
ip pim dense-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.1111.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 2 metric 1
network 172.25.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 10.2.2.2 remote-as 2
neighbor 10.2.2.2 update-source Loopback0
neighbor 10.2.2.3 remote-as 2
neighbor 10.2.2.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 vrf green
no synchronization
redistribute rip
exit-address-family
!
ip pim ssm default
!
R9
confighostname CE2A
!
ip multicast-routing
!
interface Serial0/0
ip address 172.17.12.10 255.255.255.0
ip pim sparse-mode
ip igmp join-group 239.1.1.1
serial restart-delay 0
!
router rip
version 2
network 172.17.0.0
no auto-summary
!
R10
confighostname CE2B
!
ip multicast-routing
!
interface Serial0/0
ip address 172.18.22.10 255.255.255.0
ip pim sparse-mode
ip igmp join-group 239.2.2.2
serial restart-delay 0
!
router rip
version 2
network 172.18.0.0
no auto-summary
!
R11
confighostname CE1A
!
ip multicast-routing
!
interface Serial0/0
ip address 172.25.11.10 255.255.255.0
ip pim dense-mode
ip igmp join-group 239.1.1.1
serial restart-delay 0
!
router rip
version 2
network 172.25.0.0
no auto-summary
!
R12
confighostname CE1B
!
ip multicast-routing
!
interface Serial0/0
ip address 172.25.111.10 255.255.255.0
ip pim dense-mode
ip igmp join-group 239.2.2.2
serial restart-delay 0
!
router rip
version 2
network 172.25.0.0
no auto-summary
!
Reference
이 문제에 관하여(Inter-AS mVPN Option A Pattern-1 : 각 AS 간의 멀티 캐스트에 SSM 사용), 우리는 이곳에서 더 많은 자료를 발견하고 링크를 클릭하여 보았다
https://qiita.com/eiuemura/items/21824a9fe44c27a5460a
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
우수한 개발자 콘텐츠 발견에 전념
(Collection and Share based on the CC Protocol.)
그림-1
그림-2
config
R1
confighostname PE3A
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast-routing vrf green
!
mpls label range 1000 1999
mpls label protocol ldp
!
interface Loopback0
ip address 10.1.1.3 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 192.168.143.3 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip vrf forwarding blue
ip address 172.20.34.3 255.255.255.0
ip pim sparse-dense-mode
mpls ip
!
interface Ethernet2/0
ip vrf forwarding green
ip address 172.23.35.3 255.255.255.0
ip pim sparse-dense-mode
mpls ip
!
router isis
net 49.0000.0000.3333.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 1 metric 1
network 172.23.0.0
no auto-summary
version 2
exit-address-family
!
address-family ipv4 vrf blue
redistribute bgp 1 metric 1
network 172.20.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
bgp redistribute-internal
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
bgp redistribute-internal
redistribute rip
exit-address-family
!
address-family ipv4 vrf green
no synchronization
bgp redistribute-internal
redistribute rip
exit-address-family
!
ip pim ssm default
!
R2
confighostname PE3B
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast-routing vrf green
!
mpls label range 2000 2999
mpls label protocol ldp
!
interface Loopback0
ip address 10.2.2.3 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.16.43.3 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip vrf forwarding blue
ip address 172.20.34.4 255.255.255.0
ip pim sparse-dense-mode
mpls ip
!
interface Ethernet2/0
ip vrf forwarding green
ip address 172.23.35.4 255.255.255.0
ip pim sparse-dense-mode
!
router isis
net 49.0000.0000.3333.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 2 metric 1
network 172.23.0.0
no auto-summary
version 2
exit-address-family
!
address-family ipv4 vrf blue
redistribute bgp 2 metric 1
network 172.20.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
redistribute rip metric 1
neighbor 10.2.2.1 remote-as 2
neighbor 10.2.2.1 update-source Loopback0
neighbor 10.2.2.2 remote-as 2
neighbor 10.2.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
redistribute rip
exit-address-family
!
address-family ipv4 vrf green
no synchronization
redistribute rip
exit-address-family
!
ip pim ssm default
!
R3
confighostname P1A
!
ip multicast-routing
!
mpls label range 3000 3999
mpls label protocol ldp
!
interface Ethernet0/0
ip address 192.168.143.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip address 172.19.142.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet2/0
ip address 172.30.41.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
router isis
net 49.0000.0000.4444.00
!
R4
confighostname P1B
!
ip multicast-routing
!
mpls label range 4000 4999
!
interface Ethernet0/0
ip address 172.16.43.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip address 172.19.42.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet2/0
ip address 172.30.141.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
router isis
net 49.0000.0000.4444.00
!
R5
confighostname PE2A
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
!
mpls label range 5000 5999
mpls label protocol ldp
!
interface Loopback0
ip address 10.1.1.2 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.19.142.2 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding blue
ip address 172.17.12.2 255.255.255.0
ip pim sparse-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.2222.00
!
router rip
version 2
!
address-family ipv4 vrf blue
redistribute bgp 1 metric 1
network 172.17.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.1.1.3 remote-as 1
neighbor 10.1.1.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
redistribute rip metric 1
exit-address-family
!
ip pim ssm default
ip pim vrf blue bsr-candidate Serial1/0 0
ip pim vrf blue rp-candidate Serial1/0 group-list 1
!
access-list 1 permit 239.1.1.1
!
R6
confighostname PE2B
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
!
mpls label range 6000 6999
mpls label protocol ldp
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.19.42.2 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding blue
ip address 172.18.22.2 255.255.255.0
ip pim sparse-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.2222.00
!
router rip
!
address-family ipv4 vrf blue
redistribute bgp 2 metric 1
network 172.18.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 10.2.2.1 remote-as 2
neighbor 10.2.2.1 update-source Loopback0
neighbor 10.2.2.3 remote-as 2
neighbor 10.2.2.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
redistribute rip metric 1
exit-address-family
!
ip pim ssm default
ip pim vrf blue bsr-candidate Serial1/0 0
ip pim vrf blue rp-candidate Serial1/0 group-list 1
!
access-list 1 permit 239.2.2.2
!
R7
confighostname PE1A
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf green
!
mpls label range 7000 7999
mpls label protocol ldp
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.30.41.1 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding green
ip address 172.25.11.1 255.255.255.0
ip pim dense-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.1111.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 1 metric 1
network 172.25.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback0
neighbor 10.1.1.3 remote-as 1
neighbor 10.1.1.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 vrf green
no synchronization
redistribute rip
exit-address-family
!
ip pim ssm default
!
R8
confighostname PE1B
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf green
!
mpls label range 8000 8999
mpls label protocol ldp
!
interface Loopback0
ip address 10.2.2.1 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.30.141.1 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding green
ip address 172.25.111.1 255.255.255.0
ip pim dense-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.1111.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 2 metric 1
network 172.25.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 10.2.2.2 remote-as 2
neighbor 10.2.2.2 update-source Loopback0
neighbor 10.2.2.3 remote-as 2
neighbor 10.2.2.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 vrf green
no synchronization
redistribute rip
exit-address-family
!
ip pim ssm default
!
R9
confighostname CE2A
!
ip multicast-routing
!
interface Serial0/0
ip address 172.17.12.10 255.255.255.0
ip pim sparse-mode
ip igmp join-group 239.1.1.1
serial restart-delay 0
!
router rip
version 2
network 172.17.0.0
no auto-summary
!
R10
confighostname CE2B
!
ip multicast-routing
!
interface Serial0/0
ip address 172.18.22.10 255.255.255.0
ip pim sparse-mode
ip igmp join-group 239.2.2.2
serial restart-delay 0
!
router rip
version 2
network 172.18.0.0
no auto-summary
!
R11
confighostname CE1A
!
ip multicast-routing
!
interface Serial0/0
ip address 172.25.11.10 255.255.255.0
ip pim dense-mode
ip igmp join-group 239.1.1.1
serial restart-delay 0
!
router rip
version 2
network 172.25.0.0
no auto-summary
!
R12
confighostname CE1B
!
ip multicast-routing
!
interface Serial0/0
ip address 172.25.111.10 255.255.255.0
ip pim dense-mode
ip igmp join-group 239.2.2.2
serial restart-delay 0
!
router rip
version 2
network 172.25.0.0
no auto-summary
!
Reference
이 문제에 관하여(Inter-AS mVPN Option A Pattern-1 : 각 AS 간의 멀티 캐스트에 SSM 사용), 우리는 이곳에서 더 많은 자료를 발견하고 링크를 클릭하여 보았다
https://qiita.com/eiuemura/items/21824a9fe44c27a5460a
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
우수한 개발자 콘텐츠 발견에 전념
(Collection and Share based on the CC Protocol.)
hostname PE3A
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast-routing vrf green
!
mpls label range 1000 1999
mpls label protocol ldp
!
interface Loopback0
ip address 10.1.1.3 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 192.168.143.3 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip vrf forwarding blue
ip address 172.20.34.3 255.255.255.0
ip pim sparse-dense-mode
mpls ip
!
interface Ethernet2/0
ip vrf forwarding green
ip address 172.23.35.3 255.255.255.0
ip pim sparse-dense-mode
mpls ip
!
router isis
net 49.0000.0000.3333.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 1 metric 1
network 172.23.0.0
no auto-summary
version 2
exit-address-family
!
address-family ipv4 vrf blue
redistribute bgp 1 metric 1
network 172.20.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
bgp redistribute-internal
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
bgp redistribute-internal
redistribute rip
exit-address-family
!
address-family ipv4 vrf green
no synchronization
bgp redistribute-internal
redistribute rip
exit-address-family
!
ip pim ssm default
!
hostname PE3B
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast-routing vrf green
!
mpls label range 2000 2999
mpls label protocol ldp
!
interface Loopback0
ip address 10.2.2.3 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.16.43.3 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip vrf forwarding blue
ip address 172.20.34.4 255.255.255.0
ip pim sparse-dense-mode
mpls ip
!
interface Ethernet2/0
ip vrf forwarding green
ip address 172.23.35.4 255.255.255.0
ip pim sparse-dense-mode
!
router isis
net 49.0000.0000.3333.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 2 metric 1
network 172.23.0.0
no auto-summary
version 2
exit-address-family
!
address-family ipv4 vrf blue
redistribute bgp 2 metric 1
network 172.20.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
redistribute rip metric 1
neighbor 10.2.2.1 remote-as 2
neighbor 10.2.2.1 update-source Loopback0
neighbor 10.2.2.2 remote-as 2
neighbor 10.2.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
redistribute rip
exit-address-family
!
address-family ipv4 vrf green
no synchronization
redistribute rip
exit-address-family
!
ip pim ssm default
!
hostname P1A
!
ip multicast-routing
!
mpls label range 3000 3999
mpls label protocol ldp
!
interface Ethernet0/0
ip address 192.168.143.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip address 172.19.142.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet2/0
ip address 172.30.41.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
router isis
net 49.0000.0000.4444.00
!
hostname P1B
!
ip multicast-routing
!
mpls label range 4000 4999
!
interface Ethernet0/0
ip address 172.16.43.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet1/0
ip address 172.19.42.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Ethernet2/0
ip address 172.30.141.5 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
router isis
net 49.0000.0000.4444.00
!
hostname PE2A
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
!
mpls label range 5000 5999
mpls label protocol ldp
!
interface Loopback0
ip address 10.1.1.2 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.19.142.2 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding blue
ip address 172.17.12.2 255.255.255.0
ip pim sparse-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.2222.00
!
router rip
version 2
!
address-family ipv4 vrf blue
redistribute bgp 1 metric 1
network 172.17.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.1.1.3 remote-as 1
neighbor 10.1.1.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
redistribute rip metric 1
exit-address-family
!
ip pim ssm default
ip pim vrf blue bsr-candidate Serial1/0 0
ip pim vrf blue rp-candidate Serial1/0 group-list 1
!
access-list 1 permit 239.1.1.1
!
hostname PE2B
!
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
!
mpls label range 6000 6999
mpls label protocol ldp
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.19.42.2 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding blue
ip address 172.18.22.2 255.255.255.0
ip pim sparse-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.2222.00
!
router rip
!
address-family ipv4 vrf blue
redistribute bgp 2 metric 1
network 172.18.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 10.2.2.1 remote-as 2
neighbor 10.2.2.1 update-source Loopback0
neighbor 10.2.2.3 remote-as 2
neighbor 10.2.2.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
redistribute rip metric 1
exit-address-family
!
ip pim ssm default
ip pim vrf blue bsr-candidate Serial1/0 0
ip pim vrf blue rp-candidate Serial1/0 group-list 1
!
access-list 1 permit 239.2.2.2
!
hostname PE1A
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf green
!
mpls label range 7000 7999
mpls label protocol ldp
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.30.41.1 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding green
ip address 172.25.11.1 255.255.255.0
ip pim dense-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.1111.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 1 metric 1
network 172.25.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback0
neighbor 10.1.1.3 remote-as 1
neighbor 10.1.1.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 vrf green
no synchronization
redistribute rip
exit-address-family
!
ip pim ssm default
!
hostname PE1B
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf green
!
mpls label range 8000 8999
mpls label protocol ldp
!
interface Loopback0
ip address 10.2.2.1 255.255.255.255
ip pim sparse-mode
ip router isis
!
interface Ethernet0/0
ip address 172.30.141.1 255.255.255.0
ip pim sparse-mode
ip router isis
mpls ip
!
interface Serial1/0
ip vrf forwarding green
ip address 172.25.111.1 255.255.255.0
ip pim dense-mode
no fair-queue
serial restart-delay 0
!
router isis
net 49.0000.0000.1111.00
!
router rip
version 2
!
address-family ipv4 vrf green
redistribute bgp 2 metric 1
network 172.25.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 10.2.2.2 remote-as 2
neighbor 10.2.2.2 update-source Loopback0
neighbor 10.2.2.3 remote-as 2
neighbor 10.2.2.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 vrf green
no synchronization
redistribute rip
exit-address-family
!
ip pim ssm default
!
hostname CE2A
!
ip multicast-routing
!
interface Serial0/0
ip address 172.17.12.10 255.255.255.0
ip pim sparse-mode
ip igmp join-group 239.1.1.1
serial restart-delay 0
!
router rip
version 2
network 172.17.0.0
no auto-summary
!
hostname CE2B
!
ip multicast-routing
!
interface Serial0/0
ip address 172.18.22.10 255.255.255.0
ip pim sparse-mode
ip igmp join-group 239.2.2.2
serial restart-delay 0
!
router rip
version 2
network 172.18.0.0
no auto-summary
!
hostname CE1A
!
ip multicast-routing
!
interface Serial0/0
ip address 172.25.11.10 255.255.255.0
ip pim dense-mode
ip igmp join-group 239.1.1.1
serial restart-delay 0
!
router rip
version 2
network 172.25.0.0
no auto-summary
!
hostname CE1B
!
ip multicast-routing
!
interface Serial0/0
ip address 172.25.111.10 255.255.255.0
ip pim dense-mode
ip igmp join-group 239.2.2.2
serial restart-delay 0
!
router rip
version 2
network 172.25.0.0
no auto-summary
!
Reference
이 문제에 관하여(Inter-AS mVPN Option A Pattern-1 : 각 AS 간의 멀티 캐스트에 SSM 사용), 우리는 이곳에서 더 많은 자료를 발견하고 링크를 클릭하여 보았다 https://qiita.com/eiuemura/items/21824a9fe44c27a5460a텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
우수한 개발자 콘텐츠 발견에 전념 (Collection and Share based on the CC Protocol.)