hdoj1009FatMouse'트레이드(욕심 풀이)
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500
#include<stdio.h>
#include<stdlib.h>
double J[1005],F[1005];
struct node
{
double s;
int k;
}S[1000];
int cmp(const void* p1,const void* p2)
{
return ((node *)p2)->s > ((node *)p1)->s ? 1 : -1;// , ((node*)p2)->s-((node*)p1)->s;
}
int main()
{
double m;
int n;
while(scanf("%lf%d",&m,&n)!=EOF)
{
if(m==-1&&n==-1) break;
for(int i=0;i<n;i++)
{ scanf("%lf%lf",&J[i],&F[i]);
S[i].s=J[i]/F[i];
S[i].k=i;
}
qsort(S,n,sizeof(S[0]),cmp);
double f=0;
int j=0;
for(int j=0;j<n;j++)
{
if(F[S[j].k]<=m)
{
f=f+J[S[j].k];
m=m-F[S[j].k];
}
else
{
double k1=m/F[S[j].k];
f=f+J[S[j].k]*k1;
break;
}
}
printf("%.3lf/n",f);
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Ruby의 구조체 클래스은 접근자 메서드가 있는 속성 모음입니다. 클래스를 명시적으로 작성할 필요 없이. Struct 클래스는 구성원 및 해당 값 집합을 포함하는 새 하위 클래스를 생성합니다. 각 멤버에 대해 #attr_accessor 와...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.