BestCoder_Pairs

pairs
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 0    Accepted Submission(s): 0
Problem Description

   
   
   
   
John has n points on the X axis, and their coordinates are (x[i],0),(i=0,1,2,,n1) . He wants to know how many pairs <a,b> that |x[b]x[a]|k.(a<b)

 
Input

   
   
   
   
The first line contains a single integer T (about 5), indicating the number of cases.
Each test case begins with two integers n,k(1n100000,1k109) .
Next n lines contain an integer x[i](109x[i]109) , means the X coordinates.

 
Output

   
   
   
   
For each case, output an integer means how many pairs <a,b> that |x[b]x[a]|k .

 
Sample Input

   
   
   
   
2 5 5 -100 0 100 101 102 5 300 -100 0 100 101 102

 
Sample Output

   
   
   
   
3 10
! , . , | x [ b ] x [ a ] |, . ! ......
<span style="font-family: Menlo, Monaco, Consolas, 'Courier New', monospace; font-size: 14px; line-height: 1.42857143; white-space: pre-wrap;">import java.io.*;
import java.util.*;

public class Main
{

	public static void main(String[] args)
	{
		// TODO Auto-generated method stub
		Scanner input = new Scanner(System.in);
		int t = input.nextInt();
		for (int i = 0; i < t; i++)
		{
			int n = input.nextInt();
			int a[] = new int[n];
			int sum = 0, flag = 0;
			int k = input.nextInt();
			for (int j = 0; j < n; j++)
			{
				a[j] = input.nextInt();
			}
			for (int j = 0; j < n; j++)
			{
				for (int l = j + 1; l < n; l++)
				{
					if (a[j] - a[l] < 0)
					{
						flag = -(a[j] - a[l]);
					} else
					{
						flag = a[j] - a[l];
					}
					if (flag <= k)
					{
						sum++;
					}
				}
			}
			System.out.println(sum);
		}
	}

}
</span>

pairs


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 483    Accepted Submission(s): 234


John  X    
     
      n
     
     
      (x[i],0),(i=0,1,2,,n1)
     
     
      <a,b>
       
     
      |x[b]x[a]|k(a<b)
     
          
     
      T
     (  5),        。
       ,      
     
      n,k(1n100000,1k109)
     
     
      n
     
     
      x[i](109x[i]109)
     

     
      <a,b>
       
     
      |x[b]x[a]|k
     
2
5 5
-100
0
100
101
102
5 300
-100
0
100
101
102
3
10

Statistic |  Submit |  Clarifications |  Back

좋은 웹페이지 즐겨찾기