[백준] 18258번 : 큐 2

📌 문제

정수를 저장하는 큐를 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.

명령은 총 여섯 가지이다.

  • push X : 정수 X를 큐에 넣는 연산이다.
  • pop : 큐에서 가장 앞에 있는 정수를 빼고, 그 수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • size : 큐에 들어있는 정수의 개수를 출력한다.
  • empty : 큐가 비어있으면 1, 아니면 0을 출력한다.
  • front : 큐의 가장 앞에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
  • back : 큐의 가장 뒤에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.

입력

첫째 줄에 주어지는 명령의 수 N(1≤N≤2,000,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.

출력

출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.

예제 입력 1

15
push 1
push 2
front
back
size
empty
pop
pop
pop
size
empty
pop
push 3
empty
front

예제 출력 1

1
2
2
0
1
2
-1
0
1
-1
0
3

📌 풀이

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.LinkedList;

public class Main {

    static BufferedReader br = new BufferedReader(new InputStreamReader(System.in));

    static StringBuilder sb = new StringBuilder();

    static int N;

    static LinkedList<Integer> queue = new LinkedList<>();

    public static void base() throws IOException {
        N = Integer.parseInt(br.readLine());
    }

    public static void main(String[] args) throws IOException {
        base();

        for(int i=0; i<N; i++) {
            String s = br.readLine();
            String s1[] = s.split(" ");

            switch(s1[0]) {
                case "push" :
                    push(Integer.parseInt(s1[1]));
                    break;
                case "pop" :
                    pop();
                    break;
                case "size" :
                    size();
                    break;
                case "empty" :
                    empty();
                    break;
                case "front" :
                    front();
                    break;
                case "back" :
                    back();
                    break;
            }
        }
        System.out.println(sb);
    }

    public static void push(int n) {
        queue.add(n);
    }

    public static void pop() {
        if(queue.isEmpty())
            sb.append("-1\n");
        else
            sb.append(queue.pop() + "\n");
    }

    public static void size() {
        sb.append(queue.size() + "\n");
    }

    public static void empty() {
        if(queue.isEmpty())
            sb.append("1\n");
        else
            sb.append("0\n");
    }

    public static void front() {
        if(queue.isEmpty())
            sb.append("-1\n");
        else
            sb.append(queue.getFirst() + "\n");
    }

    public static void back() {
        if(queue.isEmpty())
            sb.append("-1\n");
        else
            sb.append(queue.getLast() + "\n");
            queue.peek();
    }
}

📌 정리

LinkedList push() vs add()

1. LInkedList push()
LinkedList<Integer> queue = new LinkedList<>();
		
queue.push(1);
queue.push(2);
queue.push(3);
queue.push(4);
queue.push(5);

for(int i=0; i<queue.size(); i++) {
   System.out.print(queue.get(i) + " ");
}

=> 출력 : 5 4 3 2 1

즉, push()는 앞에서부터 값을 넣어서 저장한다.

public void push(E e) {
   addFirst(e);
}
2. LInkedList add()
LinkedList<Integer> queue = new LinkedList<>();
		
queue.add(1);
queue.add(2);
queue.add(3);
queue.add(4);
queue.add(5);
		
for(int i=0; i<queue.size(); i++) {
   System.out.print(queue.get(i) + " ");
}

=> 출력 : 1 2 3 4 5

즉, add()는 뒤에서부터 값을 넣어서 저장한다.

public boolean add(E e) {
   linkLast(e);
   return true;
}

좋은 웹페이지 즐겨찾기