POJ 2305
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 4502
Accepted: 1904
Description
Given a base b and two non-negative base b integers p and m, compute p mod m and print the result as a base b integer. p mod m is defined as the smallest non-negative integer k such that p = a*m + k for some integer a.
Input
Input consists of a number of cases. Each case is represented by a line containing three unsigned integers. The first, b, is a decimal number between 2 and 10. The second, p, contains up to 1000 digits between 0 and b-1. The third, m, contains up to 9 digits between 0 and b-1. The last case is followed by a line containing 0.
Output
For each test case, print a line giving p mod m as a base-b integer.
Sample Input
2 1100 101
10 123456789123456789123456789 1000
0
Sample Output
10
789
Source
Waterloo local 2003.09.20
이 문 제 는 JAVA 의 매우 NB 기능 인 진법 전환 을 활용 했다.
함수:
String st = Integer.toString(num, base);//num 을 10 진법 의 수로 베이스 진법 의 st (base < = 35) 로 변환 합 니 다.
int num = Integer.parseInt(st, base);//st 를 base 진법 으로 하고 10 진법 으로 전환 하 는 int (parseInt 는 두 개의 인자 가 있 습 니 다. 첫 번 째 는 바 꿀 문자열 이 고 두 번 째 는 어떤 진법 인지 설명 합 니 다).
BigInter m = new BigInteger(st, base);//st 는 문자열 이 고 base 는 st 의 진법 입 니 다.
1. 큰 숫자 를 2 진법 으로 읽 으 려 면 cin. nextBigInteger (2) 를 사용 할 수 있 습 니 다.
물론 다른 진법 으로 읽 을 수도 있다.
2. 하나의 대 수 를 다른 진 형식의 문자열 로 바 꾸 려 면 cin. toString (2) 을 사용 합 니 다./그것 을 2 진 표시 문자열 로 변환 합 니 다.
import java.io.*;
import java.util.*;
import java.math.*;
/**
*
* @author XM_zhou
*/
public class Main
{
public static void main(String[] args)
{
Scanner cin = new Scanner(System.in);
BigInteger a , b;
String str;
int n ;
while(cin.hasNext())
{
n = cin.nextInt();
if(n == 0)break;
a = cin.nextBigInteger(n);
b = cin.nextBigInteger(n);
a = a.mod(b);
str = a.toString(n);
System.out.println(str);
}
}
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Is Eclipse IDE dying?In 2014 the Eclipse IDE is the leading development environment for Java with a market share of approximately 65%. but ac...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.