POJ 1004

1900 단어 자바poj
Financial Management
Time Limit: 1000MS
 
Memory Limit: 10000K
Total Submissions: 157917
 
Accepted: 60395
Description
Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
Sample Input
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output
$1581.42
import java.text.DecimalFormat;
import java.util.Scanner;

public class Poj1004 {
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		float resultVal = 0;
		
		for(int i=0; i<12; i++){
			String temp = sc.nextLine();
			float balanceVal = Float.valueOf(temp);
			resultVal += balanceVal;
		}
		
		resultVal = resultVal/12;
		
		//   
		DecimalFormat df = new DecimalFormat(".00");
		String temp = df.format(resultVal);
		System.out.println("$"+temp);
	}
	
}

좋은 웹페이지 즐겨찾기