How many Fibs?(자바 대수)
Problem:
How many Fibs?
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 10628
Accepted: 3947
Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n>=3)
Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a,b].
Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a=b=0. Otherwise, a<=b<=10
100. The numbers a and b are given with no superfluous leading zeros.
Output
For each test case output on a single line the number of Fibonacci numbers fi with a<=fi<=b.
Sample Input
10 100
1234567890 9876543210
0 0
Sample Output
5
4
Source
Ulm Local 2000
import java.util.*;
import java.io.*;
import java.math.*;
import java.text.*;
public class pes {
public static void main(String[] args)
{
BigInteger x,y,f1,f2,t;
BigInteger ans;
Scanner cin=new Scanner(System.in);
while(cin.hasNext())
{
x=cin.nextBigInteger();
y=cin.nextBigInteger();
if(x.compareTo(BigInteger.valueOf(0))==0&&y.compareTo(BigInteger.ZERO)==0)
break;
ans=BigInteger.ZERO;
f1=BigInteger.ONE;
f2=BigInteger.valueOf(2);
while(f1.compareTo(x)<0)
{
t=f2;
f2=f2.add(f1);
f1=t;
}
while(f1.compareTo(y)<=0)
{
ans=ans.add(BigInteger.ONE);
t=f2;
f2=f2.add(f1);
f1=t;
}
System.out.println(ans);
}
}
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Is Eclipse IDE dying?In 2014 the Eclipse IDE is the leading development environment for Java with a market share of approximately 65%. but ac...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.