HDOJ / HDU 2560 건물 (음 ~ 물 문제)
Input Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands for green.
Output Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.
Sample Input 2 2 2 1 1 0 0 3 3 1 0 1 0 0 1 1 1 0
Sample Output 2 5
물 문제 하나 ~ ~ 바로 한 학교 n * m 의 면적, 그리고 건축 이 있 습 니 다 ~ 1 대표 건축, 건축 의 총 수 를 통계 합 니 다 ~
import java.util.Scanner;
public class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int t =sc.nextInt();
while(t-->0){
int n =sc.nextInt();
int m =sc.nextInt();
int sum=0;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
int a =sc.nextInt();
if(a==1){
sum++;
}
}
}
System.out.println(sum);
}
}
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Is Eclipse IDE dying?In 2014 the Eclipse IDE is the leading development environment for Java with a market share of approximately 65%. but ac...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.