HDOJ/HDU 1297 Children 's Queue (유도 ~ 대수)

3685 단어 자바ACM대수
Problem Description There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
Input There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
Output For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
Sample Input 1 2 3
Sample Output 1 2 4
제목: n 명, 일렬 로 서 라.한 가지 요구 가 있 습 니 다. (F) 여 자 는 남자 사이 에 혼자 서 있 으 면 안 됩 니 다.여자 없어 도 돼.
출력 에는 몇 가지 역법 이 있 습 니까?(사람과 사람의 차 이 를 고려 하지 않 고 위치 와 남녀 의 차이 만 을 고려한다) (만약 한 줄 이 MF 로 끝난다 면 비합법적 이다)
분석: 만약 n 개인의 역법 이 db [n] 이 라면;앞의 유도 db [n].db [n - 1] 끝 에 M 을 추가 하면 반드시 가능 합 니 다.db [n - 2] 엔 딩 에 FF 를 추가 하 는 것 도 가능 합 니 다.MF 를 추가 하면 안 됩 니 다. MM 을 추가 해도 됩 니 다. (그러나 이 경우 db [n - 1] 과 중복 되 었 습 니 다.) FM 을 추가 하 는 것 도 db [n - 1] + M 과 중복 되 었 습 니 다.
불가 서열 뒤에 FF (MF 불가, FF 추가) 를 더 하면 합 법 적 이 므 로 db [n - 4] 뒤에 + MFFF 가 가능 합 니 다. 사실 F 를 더 해도 합 법 적 입 니 다. 그러나 이러한 상황 은 db [n - 2] (+ FF 와 상당 합 니 다) 에 포함 되 어 있 습 니 다.
그래서 푸 시 방정식 db [n] = db [n - 1] + db [n - 2] + db [n - 4];
db [i] 에 저 장 된 것 은 모두 합 법 적 인 서열 수 입 니 다.
자바 대수 초 A ~ ~ ~
import java.math.BigInteger;
import java.util.Scanner;

public class Main{
    static BigInteger db[] = new BigInteger[1001];
    public static void main(String[] args) {
        dabiao();
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n =sc.nextInt();
            System.out.println(db[n]);
        }
    }
    private static void dabiao() {
        db[0]=new BigInteger("1");
        db[1]=new BigInteger("1");
        db[2]=new BigInteger("2");
        db[3]=new BigInteger("4");
        db[4]=new BigInteger("7");
        for(int i=5;i<db.length;i++){
            db[i]=db[i-1].add(db[i-2]).add(db[i-4]);
        }
    }
}

좋은 웹페이지 즐겨찾기