HDOJ/HDU 1113 Word Amalgamation (사전 순서 ~ 지도)

Problem Description In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.
Input The input contains four parts:
  • a dictionary, which consists of at least one and at most 100 words, one per line;
  • a line containing XXXXXX, which signals the end of the dictionary;
  • one or more scrambled `words’ that you must unscramble, each on a line by itself; and
  • another line containing XXXXXX, which signals the end of the file.

  • All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X’s.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.
    Output For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line “NOT A VALID WORD” instead. In either case, output a line containing six asterisks to signal the end of the list.
    Sample Input tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX
    Sample Output
    score
    ******
    refund
    ******
    part
    tarp
    trap
    ******
    NOT A VALID WORD
    ******
    course
    ******
    

    제목: 사전 XXXXX 를 입력 하여 사전 의 입력 을 끝내 고 문자열 을 입력 하 십시오. 문자열 이 사전 의 문자열 을 구성 할 수 있다 면 이 문자열 을 출력 하 십시오. 그렇지 않 으 면 NOT A VALID WORD 를 출력 하 는 것 은 사전 에서 같은 자모 로 구 성 된 문자열 을 찾 는 것 입 니 다.(찾 은 문자열 이 많 으 면 사전 순서대로 출력 해 야 합 니 다!)
    import java.util.ArrayList;
    import java.util.Arrays;
    import java.util.Comparator;
    import java.util.HashMap;
    import java.util.List;
    import java.util.Map;
    import java.util.Scanner;
    
    /** * @author     * 2016-5-27 */
    public class Main{
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                String str="";
                String chStr="";
                Map<String , List<String>> map = new HashMap<String, List<String>>();
                while(true){
                    List<String> list = new ArrayList<String>();
                    str=sc.next();
                    if("XXXXXX".equals(str)){
                        break;
                    }
                    char ch[] = str.toCharArray();
                    Arrays.sort(ch);
                    chStr=new String(ch);
    
                    if(map.get(chStr)==null){
                        list.add(str);
                        map.put(chStr, list);
                    }else{
                        list = map.get(chStr);
                        list.add(str);
                        map.put(chStr, list);
                    }
                }
    
                while(true){
                    str=sc.next();
                    if("XXXXXX".equals(str)){
                        break;
                    }
                    char ch[] = str.toCharArray();
                    Arrays.sort(ch);
                    chStr=new String(ch);
                    List<String> list = map.get(chStr);
                    if(list==null){
                        System.out.println("NOT A VALID WORD");
                    }else{
                        String strs[] = new String[list.size()];
                        for(int i=0;i<list.size();i++){
                            strs[i]=list.get(i);
                        }
                        Arrays.sort(strs, new Comparator<String>() {
                            @Override
                            public int compare(String o1, String o2) {
                                return o1.compareTo(o2);
                            }
                        });
                        for(int i=0;i<strs.length;i++){
                            System.out.println(strs[i]);
                        }
                    }
                    System.out.println("******");
                }
            }
        }
    }
    

    좋은 웹페이지 즐겨찾기