HDOJ 1016 프 라 임 링 문제 [심층 검색]

5494 단어 자바ACM
Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input n (0 < n < 20).
Output The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input 6 8
Sample Output Case 1: 1 4 3 2 5 6 1 6 5 2 3 4
Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        int Case = 0;
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            int a[] = new int[n];
            //    1-n
            int color[] = new int[n];
            //          
            int prant[] = new int[n];
            //      
            int count =0;//   
            for(int i=0;i<n;i++){
                a[i]=i+1;
                color[i] = -1;
            }//     

            Case++;
            System.out.println("Case "+(Case)+":");

            dfs(a,color,prant,count,0);
            System.out.println();



        }
    }

    private static void dfs(int[] a, int[] color, int[] prant, int count,int m) {
        //System.out.println(count);
        count++;//    1
        if(count == a.length&&p(prant[0],a[m])){
        //                      
            prant[count-1]=a[m];
            for(int i=0;i<a.length-1;i++){
                System.out.print(prant[i]+" ");
            }
            System.out.println(prant[a.length-1]);

            //return ;
        }

        for(int i=0;i<a.length;i++){
            color[m] =1;
            if(p(a[m],a[i])&&color[i]==-1){
                color[i]=1;
                prant[count-1]=a[m];

                dfs(a,color,prant,count,i);

                color[i]=-1;


            }


        }


    }

//       
    private static boolean p(int i, int j) {
        int sum = i+j;
        for(int a=2;a*a<=sum;a++){
            if(sum%a==0){
                return false;
            }
        }
        return true;
    }


}

좋은 웹페이지 즐겨찾기