F - Ride to School(2.1.2)
3568 단어 TO데이터 구조C++RIDESchool2.1.2
Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus – Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike.
We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit – he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one.
We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.
Input
There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:
Vi [TAB] Ti
Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.
Output
Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.
Sample Input
4
20 0
25 -155
27 190
30 240
2
21 0
22 34
0
Sample Output
780
771
: ,charly 0 , 。 charly 0 ,
, 。
AC :
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int n , mintime , v , t ;
while( cin >> n && n != 0 )
{
mintime = 10e5 ;
while( n-- )
{
cin >> v >> t;
if( ceil( t + 4.5 * 3600 / double(v) ) < mintime && t >= 0) //
{
mintime = ceil( t + 4.5 * 3600 / double(v) ) ; // charly
}
}
cout << mintime << endl ;
}
return 0;
}
처음에 내 방법 은 위의 것 이 아니 라 배열 을 사 용 했 지만 왠 지 런 타임 error!
그리고 나 서 나 는 배열 을 없 애고 최대 속도 자 를 찾 는 방식 으로 하 는데 Wrong Answer!!여전히 그 원인 을 모른다.기록 하 겠 습 니 다.만약 여러분 이 볼 수 있다 면, 그 중의 잘못 을 찾아내 면, 아래 에 메 시 지 를 남 겨 주시 면 감사 하 겠 습 니 다!
코드 는 다음 과 같 습 니 다:
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int n , ttime , vm , k , v , t ;
while( cin >> n && n != 0 )
{
vm = 10e-5 ;
k = 10e5;
while( n-- )
{
cin >> v >> t;
if( vm <= v && t >= 0)
{
vm = v ;
k = t ;
}
}
ttime = ceil( k + 4.5 * 3600 / double(vm) ) ;
cout << ttime << endl ;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
leetcode_129_Sum Root to Leaf NumbersGiven a binary tree containing digits from 0-9 only, each root-to-leaf path could represent a number. An example is th...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.