Currency Exchange (POJ 1860)
4476 단어 최단 경로Bellman-Ford
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R
AB, C
AB, R
BAand C
BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10
3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10
-2<=rate<=10
2, 0<=commission<=10
2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10
4.
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cstring>
using namespace std;
// 。 , ;
// Bellman-Ford ;
// ;
double dist[110]; //distance;
int N, M, S;
double V;
struct Edge{
int s, e; //start and end;
double r, c; // exchange rate and commission;
Edge(int ss, int ee, double rr, double cc): s(ss), e(ee), r(rr), c(cc){};
};
vector<Edge> edges;
int Bellman_Ford(int S)
{
for (int i = 1; i <= N; i++)
{
dist[i] = 0;
}
dist[S] = V;
for (int k = 1; k < N; k++)
{
bool flag = false;
for (int i = 0; i < edges.size(); i++)
{
int s = edges[i].s;
int e = edges[i].e;
double r = edges[i].r;
double c = edges[i].c;
if (dist[e] < ((dist[s] - c) * r))
{
flag = true;
dist[e] = (dist[s] - c) * r;
}
}
if (!flag)
return false;
}
for (int i = 0; i < edges.size(); i++)
{
int s = edges[i].s;
int e = edges[i].e;
int r = edges[i].r;
int c = edges[i].c;
if (dist[e] < ((dist[s] - c) * r))
return true;
}
return false;
}
int main(){
cin >> N >> M >> S >> V;
int a, b;
double Rab, Cab, Rba, Cba;
for (int i = 0; i < M; i++)
{
cin >> a >> b >> Rab >> Cab >> Rba >> Cba;
edges.push_back(Edge(a, b, Rab, Cab));
edges.push_back(Edge(b, a, Rba, Cba));
}
if (Bellman_Ford(S))
cout << "YES" << endl;
else
cout << "NO" << endl;
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
[백준 13549 파이썬] 숨바꼭질 3 (골드 5, 다익스트라 or BFS)알고리즘 유형 : 다익스트라 or BFS 다익스트라 풀이 BFS 풀이 SOLVE 1) 풀이 요약 (다익스트라 풀이) 이 문제는 가중치가 0 또는 1인 그래프로 생각할 수 있다. 가중치가 모두 0 또는 양수이고, 특정...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.