Crossing River POJ1700
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 7873
Accepted: 2879
Description
A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.
Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input
1
4
1 2 5 10
Sample Output
17
제목:
몇 사람이 강을 건너고, 매번 두 사람이 한 사람이 돌아올 때마다 속도는 느린 사람이 결정한다.강을 건너는 데 걸리는 가장 짧은 시간.
분석:
강을 건너는 가장 좋은 전략의 법칙을 찾고 n개인의 강을 건너는 데 속도에 따라 작은 것에서 큰 것으로 배열한다.두 가지 가장 좋은 전략을 선택할 수 있다. ① 가장 빠르고 다음으로 빨리 지나가고 가장 빨리 돌아간다.가장 느린 것과 느린 것은 지나가고, 다음에 빨리 돌아오며, t=s[1]+s[0]+s[n-1]+s[1].② 가장 빠르고 느리게, 가장 빨리 돌아오기;가장 빠른 것과 다음 것은 빨리 지나가고, 가장 빠른 것은 t=s[n-1]+s[0]+s[n-2]+s[0]이다.둘 중 사용할 시간이 비교적 적은 정책 실행을 선택하십시오.이렇게 하면 가장 느리고 차츰차츰 강을 건너 나머지 n-2명을 순환 처리한다.n=1, n=2, n=3 시 직접 처리하면 됩니다.
프로그램 소스 코드는 다음과 같습니다.
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
freopen("in.txt","r",stdin);
int speed[1000];
int t,n,time;
cin>>t;
int i,j;
for(i=0;i<t;i++)
{
cin>>n;
memset(speed,0,sizeof(speed));
for(j=0;j<n;j++)cin>>speed[j];
sort(speed,speed+n); //
time=0;
while(n>3)
{
if(speed[1]*2 > speed[0]+speed[n-2])
time=time+speed[0]+speed[0]+speed[n-1]+speed[n-2];
else time=time+speed[1]+speed[0]+speed[n-1]+speed[1];
n=n-2;
}
if(n==3)
time=time+speed[0]+speed[1]+speed[2];
else if(n==2)
time=time+speed[1];
else if(n==1)
time=time+speed[0];
cout<<time<<endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
cocos2d Lua 학습(一)ios에서 루아 함수 호출 및 전참 방법 lua 코드: 출력 결과: lua 호출 C++ 방법: add 함수: lua 코드: 출력 결과: 함수를 호출합니다. 함수를 호출하려면 다음 협의를 따르십시오. 우선, 호출할 함...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.