POJ1745 문제 풀이 보고서

Divisibility
Time Limit: 1000MS
 
Memory Limit: 10000K
Total Submissions: 6873
 
Accepted: 2294
Description
Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16
17 + 5 + -21 - 15 = -14
17 + 5 - -21 + 15 = 58
17 + 5 - -21 - 15 = 28
17 - 5 + -21 + 15 = 6
17 - 5 + -21 - 15 = -24
17 - 5 - -21 + 15 = 48
17 - 5 - -21 - 15 = 18
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5.
You are to write a program that will determine divisibility of sequence of integers.
Input
The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space.
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value.
Output
Write to the output file the word "Divisible"if given sequence of integers is divisible by K or "Not divisible"if it's not.
Sample Input
4 7
17 5 -21 15

Sample Output
Divisible
 : n K, n K 
 : , i %k , i+1 i i+1 
 (i=0...i=n-1), 0 。。
#include<iostream>
using namespace std;

int main()
{	
	int lock[101],lock2[101],num[10010],i,j,n,m;
	while(cin>>n>>m)
	{
		memset(lock,0,sizeof(lock));
		lock[0]=1;	
		for(i=0;i<n;i++)
			cin>>num[i];
		
		for(i=0;i<n;i++)
		{
			memset(lock2,0,sizeof(lock2));
			for(j=0;j<m;j++)
				if(lock[j])
				{
					lock2[(m+j+num[i]%m)%m]=lock2[(m+j-num[i]%m)%m]=1;
				}
			for(j=0;j<m;j++)
				lock[j]=lock2[j];
		}
		if(lock[0])
			cout<<"Divisible"<<endl;
		else
			cout<<"Not divisible"<<endl;
	}
	return 0;
} 

좋은 웹페이지 즐겨찾기