Crazy tea party
Crazy tea party
Grade: 10/Discount: 0.8
Time Limit:1000MS Memory Limit:65536K
Description
n participants of << crazy tea party >> sit around the table. Each minute one pair of neighbors can change their places. Find the minimum time (in minutes) required for all participants to sit in reverse order (so that left neighbors would become right, and right - left).
InputThe first line is the amount of tests. Each next line contains one integer n (1 <= n <= 32767) - the amount of crazy tea participants.
OutputFor each number n of participants to crazy tea party print on the standard output, on a separate line, the minimum time required for all participants to sit in reverse order.
Sample Input34 5 6
Sample Output246
#include<iostream>
using namespace std;
int main()
{
int T;
int n;
int temp;
int a,b;
cin>>T;
while(T--)
{
cin>>n;
if(n%2==0)
{
temp=(n/2-1)*n/2;
}
else
{
a=n/2;
b=n-n/2;
temp=((a-1)*a+(b-1)*b)/2;
}
cout<<temp<<endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
cocos2d Lua 학습(一)
ios에서 루아 함수 호출 및 전참 방법
lua 코드:
출력 결과:
lua 호출 C++ 방법:
add 함수:
lua 코드:
출력 결과:
함수를 호출합니다.
함수를 호출하려면 다음 협의를 따르십시오.
우선, 호출할 함...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.
#include<iostream>
using namespace std;
int main()
{
int T;
int n;
int temp;
int a,b;
cin>>T;
while(T--)
{
cin>>n;
if(n%2==0)
{
temp=(n/2-1)*n/2;
}
else
{
a=n/2;
b=n-n/2;
temp=((a-1)*a+(b-1)*b)/2;
}
cout<<temp<<endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
cocos2d Lua 학습(一)ios에서 루아 함수 호출 및 전참 방법 lua 코드: 출력 결과: lua 호출 C++ 방법: add 함수: lua 코드: 출력 결과: 함수를 호출합니다. 함수를 호출하려면 다음 협의를 따르십시오. 우선, 호출할 함...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.