Crazy tea party


Crazy tea party


Grade: 10/Discount: 0.8
Time Limit:1000MS Memory Limit:65536K
Description
n participants of << crazy tea party >> sit around the table. Each minute one pair of neighbors can change their places. Find the minimum time (in minutes) required for all participants to sit in reverse order (so that left neighbors would become right, and right - left).
InputThe first line is the amount of tests. Each next line contains one integer n (1 <= n <= 32767) - the amount of crazy tea participants.
OutputFor each number n of participants to crazy tea party print on the standard output, on a separate line, the minimum time required for all participants to sit in reverse order.
Sample Input34 5 6
Sample Output246
 
#include<iostream>
using namespace std;
int main()
{
     int T;
   int n;
    int temp;
    int a,b;
   cin>>T;
   while(T--)
    {
        cin>>n;
        if(n%2==0)
        {
            temp=(n/2-1)*n/2;        
       }
        else 
       {
            a=n/2;
            b=n-n/2;
            temp=((a-1)*a+(b-1)*b)/2;

       }
       cout<<temp<<endl;

    }
return 0;
}

좋은 웹페이지 즐겨찾기