C 언어 실험 - 어느 해 어느 달의 일수 (자바 작성)

1262 단어 Java
C 언어 실험 - 어느 해 어느 달의 일수
Time Limit: 1000 ms 
Memory Limit: 65536 KiB
Submit  Statistic
Problem Description
년 과 월 을 입력 하여 이 달 이 며칠 인지 판단 합 니까?
Input
년 과 월 을 입력 하 십시오. 형식 은 년\월 입 니 다.
Output
이 달의 일 수 를 출력 하 다.
Sample Input
2009\1

Sample Output
31
           ,                             ;            Java split      
   ,          ‘\’,         , Java  \\\\   \\
 
   
//package hello;

import java.util.*;

public class Main {
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		String temp;
		int flag = 0;
		int days = 0;
		temp = cin.next();
		String s[]; 
		s = temp.split("\\\\");
		int year, month;
		year = Integer.valueOf(s[0]);
		month = Integer.valueOf(s[1]);
		if((year%4==0&&year%100!=0)||(year%400==0))
	        flag=1;
	    if(month==1||month==3||month==5||month==7||month==8||month==10||month==12)
	        days=31;
	    if(month==4||month==6||month==9||month==11)
	        days=30;
	    if(flag==1&&month==2)
	        days=29;
	    if(flag==0&&month==2)
	        days=28;
	    System.out.println(days);
		cin.close();
	}
}

좋은 웹페이지 즐겨찾기