Sums

                                                                   Sums


Description


Sometimes Ziwen need to operate even larger numbers. A limit of 1000 digits is so small… You have to find the sum of two numbers with maximal size of 1 000 000 digits.

Input


The first line contains a single integer N that is the length of the given integers(1 ≤ N ≤ 1 000 000). It is followed by these integers written in columns. That is, the next N lines contain two digits each, divided by a space. Each of the two given integers is not less than 0, and the length of their sum does not exceed N. The integers may contain leading zeroes.

Output


Output exactly N digits in a single line representing the sum of these two integers.

Sample Input



0   4
4   2
6   8
3   7
Sample Output
4750
제목: 영어가 그렇게 많은데 못 알아볼 것 같아...다행히 예시는 무엇을 해야 할지 쉽게 알 수 있다.
n을 입력하면 구하는 수의 자릿수를 표시하고, 다음 n줄은 줄마다 0~9의 숫자를 두 개 입력하고, 당신이 해야 할 일은 첫 번째 열로 구성된 수와 두 번째 열로 구성된 수의 합을 구하는 것입니다.어때, 간단해...하지만 제목이 요구하는 수가 많습니다. 롱롱을 써야 합니다.
#include<iostream> 
using namespace std; 
int main()
{     
	long long n;     
	while(scanf("%lld",&n)!=EOF)     
	{         
		int *a=new int[n];         // a 
		int *b=new int[n];         // b 
		int *ans=new int[n];         
		memset(ans,0,sizeof(ans)*(n+1));        // ,  
		int i;         
		for(i=0;i<n;i++)         
		{             
			scanf("%d%d",&a[i],&b[i]);         
		}         
		for(i=n-1;i>=0;i--)         
		{             
			ans[i]+=a[i]+b[i];             
			if(ans[i]>=10)
			{                 
				ans[i]-=10;                 
				ans[i-1]+=1;             // , ( ...)
			}         
		}        
		for(i=0;i<n;i++)            
			printf("%d",ans[i]);       
		cout<<endl;   
	}   
	return 0; 
} 

 
 

좋은 웹페이지 즐겨찾기