구조---이산수학, 중언식
10744 단어 수학
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 9053
Accepted: 3463
Description
WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:
The meaning of a WFF is defined as follows:
Definitions of K, A, N, C, and E
w x
Kwx
Awx
Nw
Cwx
Ewx
1 1
1
1
0
1
1
1 0
0
1
0
0
0
0 1
0
1
1
1
0
0 0
0
0
1
1
1
A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.
You must determine whether or not a WFF is a tautology.
Input
Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.
Output
For each test case, output a line containing tautology or not as appropriate.
Sample Input
ApNp
ApNq
0
Sample Output
tautology
not
【 】
Waterloo Local Contest, 2006.9.30
http://poj.org/problem?id=3295
【 】
, 。
【 】
, , 。
。
ac :
#include<iostream>
#include<cstring>
#define MAX 110
using namespace std;
int a[MAX];
char str[MAX];
void calc(int p,int q,int r,int s,int t)
{
int top=0;
int t1,t2;
int len=strlen(str);
for(int i=len-1;i>=0;i--) // , a[0]
{
if(str[i]=='p') a[top++]=p;
else if(str[i]=='q') a[top++]=q;
else if(str[i]=='r') a[top++]=r;
else if(str[i]=='s') a[top++]=s;
else if(str[i]=='t') a[top++]=t;
if(str[i]=='K')
{
t1=a[--top];
t2=a[--top];
a[top++]=t1&&t2;
}
else if(str[i]=='A')
{
t1=a[--top];
t2=a[--top];
a[top++]=t1||t2;
}
else if(str[i]=='N')
{
t1=a[--top];
a[top++]=!t1;
}
else if(str[i]=='C')
{
t1=a[--top];
t2=a[--top];
if(t1==1&&t2==0)
a[top++]=0;
else a[top++]=1;
}
else if(str[i]=='E')
{
t1=a[--top];
t2=a[--top];
if(t1==t2)
a[top++]=1;
else a[top++]=0;
}
}
}
bool judge()
{
int p,q,r,s,t;
for(p=0;p<2;p++) //
for(q=0;q<2;q++)
for(r=0;r<2;r++)
for(s=0;s<2;s++)
for(t=0;t<2;t++)
{
calc(p,q,r,s,t);
if(a[0]==0)
{
return false;
}
}
return true;
}
int main()
{
while(cin>>str)
{
if(strcmp(str,"0")==0) break;
if(judge())
cout<<"tautology"<<endl;
else cout<<"not"<<endl;
}
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
게임 수학의 극좌표계이 기사는 의 6 일째 기사입니다. 올해 CEDEC의 이 계기로 최근 DirectX를 다시 공부하고 있는 게임 회사에 근무하는 엔지니어입니다. 이 기사의 대상자 평소부터 과학 프로그램을 작성하는 CG 엔지니어에게는 ...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.