STL 어플리케이션 2 POJ 1007 DNA Sorting 문제(STL 완벽 해답)
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 63845
Accepted: 25209
Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
Source
East Central North America 1998 및
이 문제는 간단한 문제에 속하므로 문제의 뜻만 읽으면 된다.제목은 바로 너로 하여금 순서를 정하게 하는 것이다. 여기는 더 이상 말하지 않겠다.하고 싶은 말은 STL의 두 가지 알고리즘입니다. 여기서 응용하는 것은sort()와 for_each()
sort()는 STL 정렬 알고리즘으로 두 가지 버전이 있는데 그것이 바로sort(RandomAccessIterator first, RandomAccessIterator last),sort(RandomAccessIterator first, RandomAccessIterator last, Functor comp)이다.
for_각 원형: for_each(InputIterator first, InputIterator last, Functor f).
STL로 작성된 AC 소스 보기:
#include <cstdio>
#include <algorithm>
using namespace std;
int n, len;
struct DNA
{
char str[64];
int val;
DNA() : val(0) {}
void evalue() {
for (int i=len-1; i>=0; i--)
for (int j=i; j>=0; j--)
if ( str[j] > str[i] ) val++;
}
}array[100];
bool comp(const DNA& a, const DNA& b) { return a.val < b.val; }
void printdna(DNA& dna) { puts(dna.str); }
int main()
{
scanf("%d%d", &len, &n);
for (int i=0; i<n; i++)
{
scanf("%s", array[i].str);
array[i].evalue();
}
sort(array, array+n, comp);
for_each(array, array+n, printdna);
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
cocos2d Lua 학습(一)ios에서 루아 함수 호출 및 전참 방법 lua 코드: 출력 결과: lua 호출 C++ 방법: add 함수: lua 코드: 출력 결과: 함수를 호출합니다. 함수를 호출하려면 다음 협의를 따르십시오. 우선, 호출할 함...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.