sequence---더미 복습

Sequence
Time Limit: 6000MS
 
Memory Limit: 65536K
Total Submissions: 5448
 
Accepted: 1666
Description
Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?
Input
The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.
Output
For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.
Sample Input
1
2 3
1 2 3
2 2 3

Sample Output
3 3 4

Source
POJ Monthly,Guang Lin
 
제목: n*m의 행렬을 주고 줄마다 하나의 원소를 취하여 n개의 원소를 포함하는 서열을 구성합니다. 모두 n^m의 서열이 있습니다.
시퀀스와 가장 작은 이전 n개의 시퀀스와
문제 해결 단계:
1. 첫 번째 서열을 데이터 1 벡터에 읽고 오름차순으로 정렬합니다.
2. 데이터를 데이터 2 벡터에 읽고 오름차순으로 정렬합니다.
data2[0] + data1[i](0<=i<=n-1)를 dataq 벡터에 읽기
쌓다
그리고 데이터2[1] + 데이터1[i](0<=i<=n-1), 데이터2[1] + 데이터1[i]가 무더기 데이터q의 정점보다 크면 종료합니다. 그렇지 않으면 삭제합니다.
더미의 정점, 데이터2[1] + 데이터1[i]를 삽입합니다.그리고 데이터2[2],...data2[n - 1]
3. 데이터q의 데이터를 데이터1에 복사하고 데이터1을 오름차순으로 정렬
4. 모든 데이터가 읽힐 때까지 2, 3단계를 순환한다.
5. 데이터 1의 데이터를 인쇄하면 결과가 됩니다.
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
    int t;
    int n,m;
    int num1[2010];
    int num2[2010];
    priority_queue<int,deque<int>,less<int> > big;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        for(int i=0;i<n;i++)
        scanf("%d",&num1[i]);
        sort(num1,num1+n);
        for(int i=1;i<m;i++)
        {
            for(int j=0;j<n;j++)
            {
                scanf("%d",&num2[j]);
                big.push(num1[0]+num2[j]);
            }
            sort(num2,num2+n);
            for(int k=1;k<n;k++)
            for(int l=0;l<n;l++)
            {
                if(num1[k]+num2[l]>big.top())
                    break;
                    big.pop();
                    big.push(num1[k]+num2[l]);
            }
            for(int k=0;k<n;k++)
            {
                num1[n-k-1]=big.top();
                big.pop();
            }
        }
        printf("%d",num1[0]);
        for(int i=1;i<n;i++)
        printf(" %d",num1[i]);
        puts("");
    }
}

 

좋은 웹페이지 즐겨찾기