주변 장치 없이 RaspberryPi 설정

환경


  • MacBook Air Mid 2013
  • macOS Catalina 10.15.4
  • Raspberry Pi Zero WH

  • SD 카드 포맷




    The Raspberry Pi's bootloader, built into the GPU and non-updateable, only has support for reading from FAT filesystems (both FAT16 and FAT32)

    Raspberry Pi는 FAT만 지원합니다.

    터미널에서 포맷


    $ diskutil list
    
    /dev/disk0 (internal, physical):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *121.3 GB   disk0
       1:                        EFI EFI                     209.7 MB   disk0s1
       2:                 Apple_APFS Container disk1         121.1 GB   disk0s2
    
    /dev/disk1 (synthesized):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      APFS Container Scheme -                      +121.1 GB   disk1
                                     Physical Store disk0s2
       1:                APFS Volume Macintosh HD - Data     856.1 KB   disk1s1
       2:                APFS Volume Preboot                 81.0 MB    disk1s2
       3:                APFS Volume Recovery                528.1 MB   disk1s3
       4:                APFS Volume VM                      3.2 GB     disk1s4
       5:                APFS Volume Macintosh HD - Data     40.7 GB    disk1s5
       6:                APFS Volume Macintosh HD            11.1 GB    disk1s6
    
    /dev/disk2 (internal, physical):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:     FDisk_partition_scheme                        *15.7 GB    disk2
       1:                  Apple_HFS raspberrypiSD           45.0 MB    disk2s1
       2:                      Linux                         15.7 GB    disk2s2
    
    /dev/disk3 (disk image):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        +2.8 GB     disk3
       1:                        EFI EFI                     209.7 MB   disk3s1
       2:                  Apple_HFS Visual Studio           2.4 GB     disk3s2
    

    목표 SD 카드를 확인. 내 경우에는 /dev/disk2였습니다.

    일단 마운트 해제합니다.
    $ diskutil unMountDisk /dev/disk2
    
    Unmount of all volumes on disk2 was successful
    

    "RPI"라는 이름으로 형식을 지정합니다.
    $ diskutil eraseDisk MS-DOS RPI /dev/disk2
    
    Started erase on disk2
    Unmounting disk
    Creating the partition map
    Waiting for partitions to activate
    Formatting disk2s2 as MS-DOS (FAT) with name RPI
    512 bytes per physical sector
    /dev/rdisk2s2: 30298816 sectors in 473419 FAT32 clusters (32768 bytes/cluster)
    bps=512 spc=64 res=32 nft=2 mid=0xf8 spt=32 hds=255 hid=411648 drv=0x80 bsec=30306304 bspf=3699 rdcl=2 infs=1 bkbs=6
    Mounting disk
    Finished erase on disk2
    

    FAT32로 포맷할 수 있었습니다.


    OS (Raspbian) 다운로드



    SD 카드에 이미지 파일 쓰기



    참고 : htps : // 코 m / 이시 하마 t / ms / f1fb1f30327373d
    $ sudo dd if=xxxxxxxx.img of=/dev/rdisk2 bs=16m
    
    Password:
    110+1 records in
    110+1 records out
    1849688064 bytes transferred in 114.354973 secs (16174968 bytes/sec)
    

    SSH 연결 설정



    SD 카드에 빈 파일 "ssh"를 만듭니다.
    $ touch /Volumes/boot/ssh
    

    Wi-Fi 설정



    참고 : htps : // 이 m / 괜찮아 / ms / 0d1 아 280 아 c58에 d8f6f999
    Wi-Fi 설정 파일을 만듭니다.
    $ touch /Volumes/boot/wpa_supplicant.conf
    

    아래와 같이 내용을 다시 씁니다. 암호를 일반 텍스트로 저장하지 않으려면 WPA 키 계산로 변환하십시오.

    wpa_supplicant.conf
    ctrl_interface=DIR=/var/run/wpa_supplicant
    GROUP=netdev
    update_config=1
    country=JP
    
    network={
        ssid="SSID"
        psk="WiFiパスワード"
    }
    

    SD 카드의 준비는 이것으로 완료.

    Raspberry Pi 시작



    참고 : h tps : // g ぉ 리아. 고오 l/bぉg/20191203-등 sp 벨 ry 피 4-세트 p/
    SD 카드를 Raspberry Pi에 꽂고 전원을 켭니다.
    1분 정도 놓으면 Mac의 터미널에 arp -a를 넣어 IP 주소를 조사한다.
    raspberrypi (192.168.x.x) at b8:27:eb:b6:28:be on en0 ifscope [ethernet]
    

    이 경우 "192.168.x.x"는 Raspberry Pi의 IP 주소입니다.

    Mac에서 ssh 연결



    Mac 터미널에서
    $ ssh [email protected] 
    
    [email protected]'s password: 
    

    비밀번호를 묻는다. 초기 비밀번호는 "raspberry"
    Linux raspberrypi 4.19.97+ #1294 Thu Jan 30 13:10:54 GMT 2020 armv6l
    
    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.
    
    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Wed May 20 13:18:00 2020 from 192.168.x.x
    
    SSH is enabled and the default password for the 'pi' user has not been changed.
    This is a security risk - please login as the 'pi' user and type 'passwd' to set a new password.
    
    pi@raspberrypi:~ $ 
    

    설치 완료!

    좋은 웹페이지 즐겨찾기