문제 풀이 보고서
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 4046
Accepted: 1838
Description
The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.
One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)
As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.
Input
Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'.
Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#').
You may assume that the maze exit is always reachable from the start point.
Output
For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.
Sample Input
2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########
Sample Output
37 5 5
17 17 9
: ,S ,E ,# ,. 。 E ,
, E。。。
: ,BFS DFS , 3KB , , ,WA , A 。。。
8 8
########
#....#.#
#....#.#
#....#.#
#....#.#
#....#.#
S......#
#E######
S E 。。WA , BUG 。。。。 。。
#include<iostream>
using namespace std;
char map[41][41],lock[41][41]; int head,rear,m,n,queue[2000];
struct mm
{
int x,y;
}mm[4]={-1,0,0,1,1,0,0,-1};
void push(int i){queue[rear++%2000]=i;}
int pop(){return queue[head++%2000];}
int bfs()
{
int x,y,step,i;
while(head!=rear)
{
x=pop(); y=pop(); step=pop();
if(map[x][y]=='E') return step;
for(i=0;i<4;i++)
if(x+mm[i].x>-1&&x+mm[i].x<m&&y+mm[i].y>-1&&y+mm[i].y<n&&(map[x+mm[i].x][y+mm[i].y]=='.'||map[x+mm[i].x][y+mm[i].y]=='E')&&lock[x+mm[i].x][y+mm[i].y]==0)
{ push(x+mm[i].x); push(y+mm[i].y); push(step+1); lock[x+mm[i].x][y+mm[i].y]=1; }
}
return 0;
}
int ldfs(int x,int y,int f)
{
if(map[x][y]=='E')
return 1;
if((map[x+mm[f].x][y+mm[f].y]=='.'||map[x+mm[f].x][y+mm[f].y]=='E')&&map[x+mm[(f+3)%4].x][y+mm[(f+3)%4].y]=='#')
return 1+ldfs(x+mm[f].x,y+mm[f].y,f);
else
if(!(map[x+mm[(f+3)%4].x][y+mm[(f+3)%4].y]=='#'))
{
return 1+ldfs(x+mm[(f+3)%4].x,y+mm[(f+3)%4].y,(f+3)%4);
}
else
return ldfs(x,y,(f+1)%4);
}
int rdfs(int x,int y,int f)
{
if(map[x][y]=='E')
return 1;
if((map[x+mm[f].x][y+mm[f].y]=='.'||map[x+mm[f].x][y+mm[f].y]=='E')&&map[x+mm[(f+1)%4].x][y+mm[(f+1)%4].y]=='#')
return 1+rdfs(x+mm[f].x,y+mm[f].y,f);
else
if(!(map[x+mm[(f+1)%4].x][y+mm[(f+1)%4].y]=='#'))
{
return 1+rdfs(x+mm[(f+1)%4].x,y+mm[(f+1)%4].y,(f+1)%4);
}
else
return rdfs(x,y,(f+3)%4);
}
int main()
{
int t,i,j,x,y,f,o;
cin>>t;
while(t--)
{
memset(lock,0,sizeof(lock));
head=rear=0;
cin>>n>>m;
for(i=0;i<m;i++)
cin>>map[i];
for(i=0;i<m;i++)
for(j=0;j<n;j++)
if(map[i][j]=='S')
goto start;
start:
for(f=0;f<4;f++)
if(i+mm[f].x>-1&&i+mm[f].x<m&&j+mm[f].y>-1&&j+mm[f].y<n&&(map[i+mm[f].x][j+mm[f].y]=='.'||map[i+mm[f].x][j+mm[f].y]=='E')&&map[i+mm[f].x+mm[(f+3)%4].x][j+mm[f].y+mm[(f+3)%4].y]=='#')
{ o=1+ldfs(i+mm[f].x,j+mm[f].y,f); break; }
else if(i+mm[f].x>-1&&i+mm[f].x<m&&j+mm[f].y>-1&&j+mm[f].y<n&&map[i+mm[f].x][j+mm[f].y]=='.'&&(map[i+mm[f].x+mm[(f+3)%4].x][j+mm[f].y+mm[(f+3)%4].y]=='.'||map[i+mm[f].x+mm[(f+3)%4].x][j+mm[f].y+mm[(f+3)%4].y]=='E'))
{ o=2+ldfs(i+mm[f].x+mm[(f+3)%4].x,j+mm[f].y+mm[(f+3)%4].y,(f+3)%4); break; }
cout<<o<<' ';
for(f=0;f<4;f++)
if(i+mm[f].x>-1&&i+mm[f].x<m&&j+mm[f].y>-1&&j+mm[f].y<n&&(map[i+mm[f].x][j+mm[f].y]=='.'||map[i+mm[f].x][j+mm[f].y]=='E')&&map[i+mm[f].x+mm[(f+1)%4].x][j+mm[f].y+mm[(f+1)%4].y]=='#')
{ o=1+rdfs(i+mm[f].x,j+mm[f].y,f); break; }
else if(i+mm[f].x>-1&&i+mm[f].x<m&&j+mm[f].y>-1&&j+mm[f].y<n&&map[i+mm[f].x][j+mm[f].y]=='.'&&(map[i+mm[f].x+mm[(f+1)%4].x][j+mm[f].y+mm[(f+1)%4].y]=='.'||map[i+mm[f].x+mm[(f+1)%4].x][j+mm[f].y+mm[(f+1)%4].y]=='E'))
{ o=2+rdfs(i+mm[f].x+mm[(f+1)%4].x,j+mm[f].y+mm[(f+1)%4].y,(f+1)%4); break; }
cout<<o<<' ';
lock[i][j]=1; push(i); push(j); push(1);
cout<<bfs()<<endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
cocos2d Lua 학습(一)ios에서 루아 함수 호출 및 전참 방법 lua 코드: 출력 결과: lua 호출 C++ 방법: add 함수: lua 코드: 출력 결과: 함수를 호출합니다. 함수를 호출하려면 다음 협의를 따르십시오. 우선, 호출할 함...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.