poj 2153 Rank List (데이터 구조 + 그림 의 용법)
6428 단어 데이터 구조
Time Limit: 10000MS
Memory Limit: 65536K
Total Submissions: 7883
Accepted: 2561
Description
Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?
Input
The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s class and you can assume that the names are different from each other.
In (N+2)-th line, you'll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam.
Output
The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.
Sample Input
3
Li Ming
A
B
2
49 Li Ming
49 A
48 B
80 A
85 B
83 Li Ming
Sample Output
1
2
:
(1) ----
(2) , , ,value 。
(3) , gets , getchar
(4)
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <map>
using namespace std;
int main()
{
int N;//N
char name[35];//
int sco;//
int rank;//
int M;//M
int score;//
//
map<string,int> stu_sco;
cin>>N;
getchar();//
for(int i = 1; i <= N; i++)
{
//
gets(name);
// , 0
stu_sco.insert(make_pair(name,0));
}
cin>>M;
getchar();//
while(M--)
{
rank = 1;
for(int i = 1; i <= N; i++)
{
cin>>score;
getchar();// 。。。。。
gets(name);
map<string,int>::iterator it = stu_sco.find(name);
it->second += score;
if(it->first.compare("Li Ming")==0)
sco = it->second;
}
for(map<string,int>::iterator it=stu_sco.begin();it!=stu_sco.end();it++)
if(it->second>sco)rank++;// ,
cout<<rank<<endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
정수 반전Udemy 에서 공부 한 것을 중얼거린다 Chapter3【Integer Reversal】 (예) 문자열로 숫자를 반전 (toString, split, reverse, join) 인수의 수치 (n)가 0보다 위 또는 ...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.