POJ1700 Crossing River 강 건너기 문제
1. 제목 정보
Crossing River
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 8897
Accepted: 3323
Description
A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.
Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input 1
4
1 2 5 10
Sample Output 17
2. 참조 코드 #include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int main()
{
int N;
cin >> N;
while(N--)
{
vector<int> a;
int n,m,sum = 0;
cin >> n;
for(int i = 1;i <= n;i++)
{
cin >> m;
a.push_back(m);
}
sort(a.begin(),a.end());
a.insert(a.begin(),0);
while(1)
{
if(n == 2)
{
sum += a[2];
break;
}
else if(n == 1)
{
sum += a[1];
break;
}
else if(n == 3)
{
sum +=a[1] + a[2] + a[3];
break;
}
else
{
sum += min(2*a[2] + a[1] + a[n] ,a[n] + 2*a[1] + a[n-1]);
a.erase(a.end()-1,a.end());
n -= 2;
}
}
cout << sum << endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
cocos2d Lua 학습(一)
ios에서 루아 함수 호출 및 전참 방법
lua 코드:
출력 결과:
lua 호출 C++ 방법:
add 함수:
lua 코드:
출력 결과:
함수를 호출합니다.
함수를 호출하려면 다음 협의를 따르십시오.
우선, 호출할 함...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.
1
4
1 2 5 10
17
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int main()
{
int N;
cin >> N;
while(N--)
{
vector<int> a;
int n,m,sum = 0;
cin >> n;
for(int i = 1;i <= n;i++)
{
cin >> m;
a.push_back(m);
}
sort(a.begin(),a.end());
a.insert(a.begin(),0);
while(1)
{
if(n == 2)
{
sum += a[2];
break;
}
else if(n == 1)
{
sum += a[1];
break;
}
else if(n == 3)
{
sum +=a[1] + a[2] + a[3];
break;
}
else
{
sum += min(2*a[2] + a[1] + a[n] ,a[n] + 2*a[1] + a[n-1]);
a.erase(a.end()-1,a.end());
n -= 2;
}
}
cout << sum << endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
cocos2d Lua 학습(一)ios에서 루아 함수 호출 및 전참 방법 lua 코드: 출력 결과: lua 호출 C++ 방법: add 함수: lua 코드: 출력 결과: 함수를 호출합니다. 함수를 호출하려면 다음 협의를 따르십시오. 우선, 호출할 함...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.