POJ1505&&UVa714 Copying Books(DP)
4358 단어 copy
Time Limit: 3000MS
Memory Limit: 10000K
Total Submissions: 7109
Accepted: 2221
Description
Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers. Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered 1, 2 ... m) that may have different number of pages (p1, p2 ... pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, ... < bk-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are integers p1, p2, ... pm separated by spaces. All these values are positive and less than 10000000.
Output
For each case, print exactly one line. The line must contain the input succession p1, p2, ... pm divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character ('/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash. If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.
Sample Input
2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100
Sample Output
100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100
Source
Central Europe 1998
제목 k 개인 복제 m 책 최소 시간
d[i][j]는 i개인이 완료되기 전 j본서의 시간 전이 방정식 d[i][j]=min(d[i][j],max(d[i-1][k],s[j]-s[k]))))k는 i-1에서 j까지의 전체 수 s[k]를 나타낸다. 첫 번째 책에서 첫 번째 k본까지의 시간과 초기 d[1][i]=s[i]를 나타낸다.
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 550, INF = 0x3f3f3f3f;
int a[N], flag[N], s[N], d[N][N], t, cas, n, m, ans;
int dp (int i, int j)
{
if (d[i][j] > 0) return d[i][j];
d[i][j] = INF;
for (int k = i - 1; k < j; ++k)
d[i][j] = min (d[i][j], max (dp (i - 1, k), s[j] - s[k]));
return d[i][j];
}
int main()
{
scanf ("%d", &cas);
while (cas--)
{
scanf ("%d%d", &n, &m);
memset (d, -1, sizeof (d)); memset (flag, -1, sizeof (flag));
for (int i = 1; i <= n; ++i)
{ scanf ("%d", &a[i]); d[1][i] = s[i] = s[i - 1] + a[i]; }
ans = dp (m, n);
for (int i = n,t=0 ; i >= 1; --i)
if ( ( (t = t + a[i]) > ans) || m > i)
{ t = a[i]; flag[i] = 0; --m; }
for (int i = 1; i <= n; ++i)
{
printf (flag[i] ? "%d" : "%d /", a[i]);
printf (i == n ?
"
" : " ");
}
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
파일 내용 및 파일 경로의 단수 및 복수 대체 텍스트를 사용하여 원본 파일을 대상에 붙여넣기기본 코드로 많은 수의 파일과 폴더를 복사하고 파일 내부의 여러 줄과 파일 및 폴더의 이름을 바꿔야 하는 경우가 많으며 시간이 많이 걸립니다😢. 이 문제를 해결하기 위해 나를 위해 할 수 있는 유틸리티를 작성했습니다...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.