POJ-1458 Common Subsequence(선형 게이지, 최대 공통 하위 시퀀스 문제)

3625 단어 dp
Common Subsequence Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 44464 Accepted: 18186 Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. Sample Input
abcfbc abfcab programming contest abcd mnp Sample Output
4 2 0
누드의 가장 긴 공공 서열 문제: 상태 이동 방정식:if(s1[i]=s2[j])dp[i][j]=dp[i-1][j-1]+1;else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>
#include <string>

using namespace std;
char s1[300];
char s2[300];
int dp[300][300];
int main()
{

    while(scanf("%s%s",&s1,&s2)!=EOF)
    {
        int len1=strlen(s1);
        int len2=strlen(s2);
                 memset(dp,0,sizeof(dp));
        for(int i=0;i<len1;i++)
        {
            for(int j=0;j<len2;j++)
            {
                if(s1[i]==s2[j])
                    dp[i+1][j+1]=dp[i][j]+1;
                else
                    dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);

            }
        }
        cout<<dp[len1][len2]<<endl;
    }
    return 0;
}

좋은 웹페이지 즐겨찾기