POJ 1274 The Perfect Stall 다이어그램 최대 일치
POJ 1274 The Perfect Stall 다이어그램 최대 일치
Description
Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.
Input
The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.
Output
For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.
Sample Input
5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2
Sample Output
4
#include <iostream>
#include <vector>
using namespace std;
typedef struct
{
int x;
int y;
}point;
const int MAXN = 201;
bool visit[MAXN];
int n,m,mark[MAXN];
vector< vector<point> >adj;
bool dfs(int pos){
point z;
int i,j,pre,len=adj[pos].size();
for(i=0;i<len;i++){
j=adj[pos][i].x;
if(!visit[j]){
visit[j]=true,pre=mark[j],mark[j]=pos;
if(pre==-1 || dfs(pre))
return true;
mark[j]=pre;
}
}
return false;
}
int hungary(){
int i,ans=0;
for(i=1;i<=n;i++){
memset(visit,false,sizeof(visit));
if(dfs(i)) ans++;
}
return ans;
}
int main(){
int i,j,t;
point z;
while(scanf("%d %d",&n,&m)!=EOF){
memset(mark,-1,sizeof(mark));
adj.assign(n+1,vector<point>());
for(i=1;i<=n;i++){
scanf("%d",&t);
while(t--){
scanf("%d",&j);
z.x=j;
adj[i].push_back(z);
}
}
printf("%d/n",hungary());
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Vector & Matrix스칼라 : 하나의 숫자로만 이루어진 데이터 (크기만 있고 방향이 없는 물리량) 벡터 : 여러 숫자로 이루어진 데이터 레코드. 매트릭스 : 벡터가 여럿인 데이터집합 벡터의 크기는 스칼라배를 통해 표현할 수 있다. *내...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.