POJ 1051 P,MTHBGWB 단순 문자열 변환
P,MTHBGWB
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 5088
Accepted: 2924
Description
Morse code represents characters as variable length sequences of dots and dashes. In practice, characters in a message are delimited by short pauses. The following table shows the Morse code sequences:
A
.-
H
....
O
---
V
...-
B
-...
I
..
P
.--.
W
.--
C
-.-.
J
.---
Q
--.-
X
-..-
D
-..
K
-.-
R
.-.
Y
-.--
E
.
L
.-..
S
...
Z
--..
F
..-.
M
--
T
-
G
--.
N
-.
U
..-
Note that four dot-dash combinations are unassigned. For the purposes of this problem we will assign them as follows (these are not the assignments for actual Morse code):
underscore
..--
period
---.
comma
.-.-
question mark
----
Thus, the message "ACM_GREATER_NY_REGION" is encoded as:
.- -.-. -- ..-- --. .-. . .- - . .-. ..-- -. -.-- ..-- .-. . --. .. --- -.
M.E. Ohaver proposed an encryption scheme based on mutilating Morse code. Her scheme replaces the pauses between letters, necessary because Morse is a variable-length encoding that is not prefix-free, with a string that identifies the number of dots and dashes in each. For example, consider the message ".--.-.--". Without knowing where the pauses should be, this could be "ACM", "ANK", or several other possibilities. If we add length information, however, ".--.-.--242", then the code is unabiguous.
Ohaver's scheme has three steps, the same for encryption and decryption:
1. Convert the text to Morse code without pauses but with a string of numbers to indicate code lengths
2. Reverse the string of numbers
3. Convert the dots and dashes back into to text using the reversed string of numbers as code lengths
As an example, consider the encrypted message "AKADTOF_IBOETATUK_IJN". Converting to Morse code with a length string yields ".--.-.--..----..-...--..-...---.-.--..--.-..--...----.232313442431121334242". Reversing the numbers and decoding yields the original message "ACM_GREATER_NY_REGION".
Input
This problem requires that you implement Ohaver's encoding algorithm. The input will consist of several messages encoded with Ohaver's algorithm. The first line of the input is an integer n that specifies the number of test cases. The following n lines contain one message per line. Each message will use only the twenty-six capital letters, underscores, commas, periods, and question marks. Messages will not exceed 100 characters in length.
Output
For each message in the input, output the line number starting in column one, a colon, a space, and then the decoded message. The output format must be adhered to precisely.
Sample Input
5
AKADTOF_IBOETATUK_IJN
PUEL
QEWOISE.EIVCAEFNRXTBELYTGD.
?EJHUT.TSMYGW?EJHOT
DSU.XFNCJEVE.OE_UJDXNO_YHU?VIDWDHPDJIKXZT?E
Sample Output
1: ACM_GREATER_NY_REGION
2: PERL
3: QUOTH_THE_RAVEN,_NEVERMORE.
4: TO_BE_OR_NOT_TO_BE?
5: THE_QUICK_BROWN_FOX_JUMPS_OVER_THE_LAZY_DOG
/* Author : yan
* Question : POJ 1051P,MTHBGWB
* Data : Monday, December 20 2010
*/
#include<stdio.h>
#define MAX 102
char str[MAX];
char code[4*MAX];
int code_len[MAX];
int cnt;
int read_cnt;
int len;
const char * dic[]={".-","-...","-.-.","-..",".","..-.","--.","....","..",".---","-.-",".-..","--","-.","---",".--.","--.-",".-.","...","-","..-","...-",".--","-..-","-.--","--..","..--","---.",".-.-","----"};
int len_of_code(char ch)
{
if(ch-'A'<26&&ch-'A'>=0) return strlen(dic[ch-'A']);
else return 4;
}
void addcode(char ch)
{
int _i;
char cache[5];
if(ch-'A'>=0&&ch-'A'<26) strcpy(cache,dic[ch-'A']);
else if(ch=='_') strcpy(cache,dic[26]);
else if(ch=='.') strcpy(cache,dic[27]);
else if(ch==',') strcpy(cache,dic[28]);
else if(ch=='?') strcpy(cache,dic[29]);
for(_i=0;cache[_i]!='/0';_i++)
{
code[cnt++]=cache[_i];
}
}
void readcode()
{
char cache[5];
int _cnt;
int _i,_j;
for(_i=len-1;_i>=0;_i--)
{
_cnt=0;
for(_j=0;_j<code_len[_i];_j++)
cache[_cnt++]=code[read_cnt++];
cache[_cnt]='/0';
for(_j=0;_j<30;_j++)
if(strcmp(cache,dic[_j])==0)
{
if(_j<26) printf("%c",_j+'A');
else if(_j==26) printf("_");
else if(_j==27) printf(".");
else if(_j==28) printf(",");
else printf("?");
}
}
}
int main()
{
int n;
int i,j;
//freopen("input","r",stdin);
scanf("%d",&n);
for(i=0;i<n;i++)
{
cnt=0;read_cnt=0;
scanf("%s",str);
len=strlen(str);
for(j=0;j<len;j++)
{
code_len[j]=len_of_code(str[j]);
addcode(str[j]);
}
printf("%d: ",i+1);
readcode();
printf("/n");
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
JavaScript의 Cache API - 단 20줄의 코드만 있으면 됩니다.이제 API를 이렇게 호출할 수 있습니다. If there is a cache value of the current api call then it will return values from cache otherwis...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.