PAT - A 급 - 1042 - Huffling Machine (20)

16043 단어 PATCSP(JAVA)
제목 설명
Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.
The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:
S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.
입력 형식:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.
출력 형식:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.
입력 예시:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

출력 예시:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

제목 정보:
저자: 첸, 유
단위: 절강대학
시간 제한: 400 ms
메모리 제한: 64 MB
코드 길이 제한: 16 KB
제목 의 대의
자동 카드 세척기
이 기 계 는 주어진 무 작위 순서에 따라 54 장의 카드 를 뒤 섞 고 일정 횟수 를 반복 한다.카드 그룹의 초기 상 태 를 다음 과 같이 가정 합 니 다.
S1,S2,…,S13,

H1,H2,…,H13,

C1,C2,…,C13,

D1,D2,…,D13,

J1、J2

스페이드♠”,하트♥”,매화♣”,'D' 는 네모 난 영 화 를 대표 한다.♦”,"J"는 "조커 (왕)"를 대표 합 니 다. 주어진 순 서 는 [1, 54] 의 서로 다른 정수 배열 입 니 다. i 번 째 위치의 숫자 가 j 라면 카드 를 위치 i 에서 위치 j 로 이동 하 는 것 을 의미 합 니 다. 예 를 들 어 우 리 는 5 장의 카드 만 있다 고 가정 합 니 다: S3, H5, C1, D13 과 J2. 카드 를 섞 는 순서 {4, 2, 5, 3, 1}결 과 는 J2, H5, D13, S3, C1 입 니 다. 만약 우리 가 다시 카드 를 섞 으 면 결 과 는 C1, H5, S3, J2, D13 입 니 다.
모든 입력 파일 에는 테스트 용례 가 포함 되 어 있 습 니 다.
첫 번 째 줄 은 정수 K (≤ 20) 를 포함 하고 중복 횟수 입 니 다.
다음 줄 은 주어진 순 서 를 포함 합 니 다. 한 줄 의 모든 숫자 는 빈 칸 으로 구분 합 니 다.
출력 규격: 모든 테스트 용례 에 대해 한 줄 에 카드 결 과 를 인쇄 합 니 다. 모든 카드 는 빈 칸 으로 분리 되 어 있 으 며 줄 의 끝 에 빈 칸 이 있어 서 는 안 됩 니 다.
분석 하 다.
제목 에서 먼저 최초의 패 순 서 를 정 하 다.
첫 줄 에 카드 를 뒤 섞 는 횟수 를 입력 하 세 요.
두 번 째 줄 은 카드 를 뒤 섞 는 방식 을 입력 한다.
예 를 들 어 초기 순 서 를 가정 하면 H1, C2, J2, D13카드 를 섞 는 방식 은 change[2, 3, 4, 1] 이다. 한 번 씻 으 면 첫 번 째 카드 를 위치 1, 두 번 째 카드 를 위치 2, 세 번 째 카드 를 위치 3, 네 번 째 카드 를 위치 0 에 놓 은 결과 D13, H1, C2, J2 이다.
두 번 째 는 첫 번 째 세탁 결과 에 상술 한 조작 을 반복 하 는 것 이다.
실제로 첫 번 째 카드 를 섞 은 후 첫 번 째 카드 는 위치 change[0], 즉 위치 2 에 도착한다.
두 번 째 카드 를 섞 은 후 첫 번 째 카드 는 위치 change[change[0]], 즉 위치 change[2], 즉 위치 3 에 도착 했다.
그래서 우 리 는 정말 카드 를 섞 지 않 아 도 된다. 이렇게 한 층 한 층 씩 끼 워 넣 고 모든 카드 의 최종 위 치 를 읽 으 면 된다. 그 다음 에 이 카드 를 최종 위치 에 놓 으 면 된다.
마지막 순서 출력
코드 순서
  • 카드 한 장 에
  • 먼저 이 카드 의 첫 번 째 카드 세탁 후의 위 치 를 설정 합 니 다 pos
  • 0 회 세탁 가능
  • 주의
  • 본 카드 를 획득 하여 첫 번 째 카드 를 섞 은 토대 에서 총 횟수 - 1 번 카드 를 섞 은 후의 위치
    for(int j=1;j<time;j++)
        pos=change[pos];
    

  • 코드 구현 - JAVA
    import java.util.*;
    
    public class Main {
        public static void main(String[] args) throws Exception{
    		Scanner sc = new Scanner(System.in);
            
            //      
    		int time = sc.nextInt();
    
    		//       
    		String[] flower = new String[54];
    		//     
    		int[] change = new int[54];
    		//          
    		int pos;
    		//       
    		int[] end = new int[54];
    		
            //       
    		for(int i = 0; i<54; i++) change[i]=sc.nextInt()-1;
            
            //         
    		int base=-1;
    		for(int i=1; i<=13; i++) flower[i+base] = "S"+i; base+=13;
    		for(int i=1; i<=13; i++) flower[i+base] = "H"+i; base+=13;
    		for(int i=1; i<=13; i++) flower[i+base] = "C"+i; base+=13;
    		for(int i=1; i<=13; i++) flower[i+base] = "D"+i; base+=13;
    		flower[52] = "J1"; flower[53]="J2";
    		
    		//     ( 54 )       
    		for(int i = 0; i < 54; i++) {
                //          0
    			if(time>0)
                    pos = change[i]; //        
    			else pos=i;
                //       -1       
    			for(int j=1;j<time;j++)
                    pos=change[pos];
                //            
    			end[pos]=i;
    		}
            //     
    		for(int i=0;i<53;i++) {
    			System.out.print(flower[end[i]]+" ");
    		}
            System.out.println(flower[end[53]]);
        }
    }
    

    좋은 웹페이지 즐겨찾기