zoj 2965
Time Limit: 1 Second
Memory Limit: 32768 KB
In a party held by CocaCola company, several students stand in a circle and play a game.
One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts a number which is a multiple of 7 (e.g. 7, 14, 28, ...) or contains the digit '7' (e.g. 7, 17, 27, ...), he shall say "CocaCola"instead of the number itself.
For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say "CocaCola"because 27 contains the digit '7'. The fourth one should say "CocaCola"too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends.
During a game, you may hear a consecutive of p "CocaCola"s. So what is the minimum number that can make this situation happen?
For example p = 2, that means there are a consecutive of 2 "CocaCola"s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation happen.
Input
Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 100) which is the number of test cases. And it will be followed by T consecutive test cases.
There is only one line for each case. The line contains only one integer p (1 <= p <= 99).
Output
Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of the p "CocaCola"s stands for.
Sample Input
2
2
3
Sample Output
27
70
//2956 method 2;
#include <iostream>
using namespace std;
int main()
{
int T;
cin>>T;
while(T--)
{
int n;
cin>>n;
if(n==1)
cout<<7<<endl;
else if ( n ==2 )
cout<<27<<endl;
else if ( n >=3 && n<=10)
cout<<70<<endl;
else if(n==11)
cout<<270<<endl;
else
cout<<700<<endl;
}
return 0;
}
//2956 method 1;
#include <iostream>
using namespace std;
bool cal(int i)
{
while(i!=0)
{
if(i%10==7)
return true;
i/=10;
}
return false;
}
int main()
{
int t;
cin>>t;
bool a[1001];
memset(a,false,sizeof(a));
for(int i = 1 ; i < 1001; i++)
{
if(i%7==0||cal(i))
{
a[i] = true;
}
}
while(t--)
{
int n;
cin>>n;
for ( int j = 1 ; j < 1001 ; j++)
{
if( a[j] == true)
{
int t = 0;
int k;
int flag = 0;
for(k = j; k < 1001; k++)
if( a[k] == true)
{
t++;
if(t==n)
{
flag = 1;
break;
}
}
else
break;
if(flag==1)
{
cout<<j<<endl;
break;
}
}
}
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
cocos2d Lua 학습(一)ios에서 루아 함수 호출 및 전참 방법 lua 코드: 출력 결과: lua 호출 C++ 방법: add 함수: lua 코드: 출력 결과: 함수를 호출합니다. 함수를 호출하려면 다음 협의를 따르십시오. 우선, 호출할 함...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.