데이터 구조의 선형 표 - 순서 생 성 링크

2432 단어 데이터 구조
데이터 구조 실험의 링크 1: 순서 로 링크 를 만 듭 니 다.
Time Limit: 1000MS Memory limit: 65536K
제목 설명
N 개의 정 수 를 입력 하고 입력 순서에 따라 단일 체인 시트 를 만들어 저장 하 며 만들어 진 단일 체인 시트 를 옮 겨 다 니 며 이 데 이 터 를 출력 합 니 다.
입력
첫 줄 에 정수 의 개수 N 입력 하기;
두 번 째 줄 은 순서대로 모든 정 수 를 입력 한다.
출력
이 정 수 를 출력 합 니 다.
예제 입력
8

12 56 4 6 55 15 33 62

예제 출력
12 56 4 6 55 15 33 62

#include <iostream>

#include <string>

#include <string.h>

#include <stdio.h>

#include <algorithm>

#include <algorithm>



using namespace std;



struct node

{

    int data;

    struct node *next;

};



int main()

{

    int n;

    int i, j;



    struct node *head;

    head=(struct node*)malloc(sizeof(struct node));  //   



    head->next=NULL;

    struct node *tail, *p;

    tail=head;



    cin>>n;

    for(i=0; i<n; i++)

    {

        p=(struct node *)malloc(sizeof(struct node));  //   

        scanf("%d", &p->data );

        p->next=NULL;

        tail->next=p;

        tail=p;

    }

    for(j=0; j<n; j++)

    {

        if(j==0)

        cout<<head->next->data;

        else

        cout<<" "<<head->next->data;

        head=head->next;

    }

    cout<<endl;



    return 0;

}


 
#include <iostream>

#include <string>

#include <string.h>

#include <stdio.h>

#include <algorithm>

#include <algorithm>



using namespace std;



struct node

{

    int data;

    struct node *next;

};



int main()

{

    int n;

    int i, j;



    struct node *head;

    head= new struct node;  //  C++ new       !



    head->next=NULL;

    struct node *tail, *p;

    tail=head;



    cin>>n;

    for(i=0; i<n; i++)

    {

        p=new struct node;

        scanf("%d", &p->data );

        p->next=NULL;

        tail->next=p;

        tail=p;

    }

    for(j=0; j<n; j++)

    {

        if(j==0)

        cout<<head->next->data;

        else

        cout<<" "<<head->next->data;

        head=head->next;

    }

    cout<<endl;



    return 0;

}


좋은 웹페이지 즐겨찾기