데이터 구조의 선형 표 - 순서 생 성 링크
2432 단어 데이터 구조
Time Limit: 1000MS Memory limit: 65536K
제목 설명
N 개의 정 수 를 입력 하고 입력 순서에 따라 단일 체인 시트 를 만들어 저장 하 며 만들어 진 단일 체인 시트 를 옮 겨 다 니 며 이 데 이 터 를 출력 합 니 다.
입력
첫 줄 에 정수 의 개수 N 입력 하기;
두 번 째 줄 은 순서대로 모든 정 수 를 입력 한다.
출력
이 정 수 를 출력 합 니 다.
예제 입력
8
12 56 4 6 55 15 33 62
예제 출력
12 56 4 6 55 15 33 62
, , !
#include <iostream>
#include <string>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <algorithm>
using namespace std;
struct node
{
int data;
struct node *next;
};
int main()
{
int n;
int i, j;
struct node *head;
head=(struct node*)malloc(sizeof(struct node)); //
head->next=NULL;
struct node *tail, *p;
tail=head;
cin>>n;
for(i=0; i<n; i++)
{
p=(struct node *)malloc(sizeof(struct node)); //
scanf("%d", &p->data );
p->next=NULL;
tail->next=p;
tail=p;
}
for(j=0; j<n; j++)
{
if(j==0)
cout<<head->next->data;
else
cout<<" "<<head->next->data;
head=head->next;
}
cout<<endl;
return 0;
}
#include <iostream>
#include <string>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <algorithm>
using namespace std;
struct node
{
int data;
struct node *next;
};
int main()
{
int n;
int i, j;
struct node *head;
head= new struct node; // C++ new !
head->next=NULL;
struct node *tail, *p;
tail=head;
cin>>n;
for(i=0; i<n; i++)
{
p=new struct node;
scanf("%d", &p->data );
p->next=NULL;
tail->next=p;
tail=p;
}
for(j=0; j<n; j++)
{
if(j==0)
cout<<head->next->data;
else
cout<<" "<<head->next->data;
head=head->next;
}
cout<<endl;
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
정수 반전Udemy 에서 공부 한 것을 중얼거린다 Chapter3【Integer Reversal】 (예) 문자열로 숫자를 반전 (toString, split, reverse, join) 인수의 수치 (n)가 0보다 위 또는 ...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.