화 웨 이 기계 시험-뱀 모양 행렬
제목 설명
뱀 모양 행렬 은 1 에서 시 작 된 자연수 가 순서대로 배 열 된 행렬 의 삼각형 이다.
샘플 입력
5
샘플 출력
1 3 6 10 15
2 5 9 14
4 8 13
7 12
11
입력 설명:
N(N 100)
출력 설명:
N 。
입력 예:
4
출력 예:
1 3 6 10
2 5 9
4 8
7
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
while (scan.hasNext()) {
int N = scan.nextInt();
scan.nextLine();
getResult(N);
}//endwhile
scan.close();
}
private static void getResult(int n) {
int[][] result = new int[n][n];
//세로 로 첫 번 째 열 채 우기
verticalFill(result);
//가로 채 우기
horizontalFill(result);
print(result);
}
private static void horizontalFill(int[][] result){
int x_distance = 2;//첫 번 째 줄 앞의 두 원소 사이 의 거리 2,가로 매번+1
int y_distance = 2;//두 번 째 줄 앞의 두 원소 사이 의 거리 3,세로 거리 매번+1
int n = result.length;
for(int i = 0 ; i < n ; i++){
x_distance = y_distance;
for(int j = 1 ; j < n - i ; j++){
result[i][j] = result[i][j - 1] + x_distance;
x_distance++;
}
y_distance++;
}
}
private static void verticalFill(int[][] result){
result[0][0] = 1;
int distance = 1;
int n = result.length;
for(int i = 1 ; i < n ; i++){
result[i][0] = result[i - 1][0] + distance;
distance++;
}
}
private static void print(int[][] result){
int length = result.length;
for(int i = 0 ; i < length ; i++){
for(int j = 0; j < length - i ; j++){
if(j == length - 1 - i){
System.out.print(result[i][j]);
}else{
System.out.print(result[i][j] + " ");
}
}
System.out.println();
}
}
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Is Eclipse IDE dying?In 2014 the Eclipse IDE is the leading development environment for Java with a market share of approximately 65%. but ac...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.