더미 응용 프로그램: Sequence
Time Limit:6000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit
Status
Practice
POJ 2442
Description
Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?
Input
The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.
Output
For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.
Sample Input
1
2 3
1 2 3
2 2 3
Sample Output
3 3 4
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <algorithm>
#include <iostream>
using namespace std;
int main(){
int n, m;
int cnt , i, j, k;
int str1[2010], str2[2010];
priority_queue<int> str;
cin >> cnt;
while(cnt--){
cin >> m >> n;
memset(str1, 0, sizeof(str1));
memset(str2, 0, sizeof(str2));
for(i = 0; i < n; i ++)
scanf("%d", &str1[i]);
sort(str1, str1 + n);
for(i = 1; i < m; i++){
for(j = 0; j < n; j++)
scanf("%d", &str2[j]);
sort(str2, str2 + n);
for(j = 0; j < n; j ++)
str.push(str2[0] + str1[j]);
for(j = 1; j < n; j ++){
for(k = 0; k < n; k ++){
if(str2[j] + str1[k] > str.top())
break;
str.pop(); // , ,
str.push(str2[j] + str1[k]);
}
}
for(j = 0; j < n; j ++){
str1[n - j -1] = str.top(); // str1
str.pop();//
}
}
for(i = 0; i < n; i ++)
{
if(i != 0)
cout<<" ";
cout<<str1[i];
}
cout<<endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
cocos2d Lua 학습(一)ios에서 루아 함수 호출 및 전참 방법 lua 코드: 출력 결과: lua 호출 C++ 방법: add 함수: lua 코드: 출력 결과: 함수를 호출합니다. 함수를 호출하려면 다음 협의를 따르십시오. 우선, 호출할 함...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.