HDU 2007 제곱 과 입방 화 (물 문제)

제곱 합 과 입방 합
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 139868    Accepted Submission(s): 44760
Problem Description
연속 적 인 정 수 를 정 하여 그들 중의 모든 짝수 의 제곱 과 모든 홀수 의 입방 과 를 구하 십시오.
 
Input
입력 데 이 터 는 여러 그룹의 테스트 인 스 턴 스 를 포함 하고 각 그룹의 테스트 인 스 턴 스 는 한 줄 을 포함 하 며 두 개의 정수 m 와 n 으로 구성 된다.
 
Output
각 그룹의 입력 데이터 에 대해 한 줄 을 출력 할 때 두 개의 정수 x 와 y 를 포함해 야 한다. 이 단락 의 연속 적 인 정수 중의 모든 짝수 의 제곱 과 모든 홀수 의 입방 과 를 나타 낸다.너 는 32 개의 정수 가 결 과 를 저장 하기에 충분 하 다 고 생각 할 수 있다.
 
Sample Input

   
   
   
   
1 3 2 5

 
Sample Output

   
   
   
   
4 28 20 152

 
Author
lcy
 
AC 코드:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
typedef long long LL;
using namespace std;

int main()
{
	int m,n;
	while(cin>>m>>n)
	{
		if(m>=n)
			swap(m,n);
		long x=0,y=0;
		for(int i=m;i<=n;i++)
		{
		if(i%2==0)
	    x+=i*i;
		else
		y+=i*i*i;
	    }
	    cout<<x<<" "<<y<<endl;
	}
	return 0;

}

좋은 웹페이지 즐겨찾기