HDOJ / HDU 1073 온라인 판사 (문자열 처리 ~)
Given the data of correct output file and the data of user’s result file, your task is to determine which result the Judge System will return.
Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case has two parts, the data of correct output file and the data of the user’s result file. Both of them are starts with a single line contains a string “START” and end with a single line contains a string “END”, these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.
Output For each test cases, you should output the the result Judge System should return.
Sample Input 4 START 1 + 2 = 3 END START 1+2=3 END START 1 + 2 = 3 END START 1 + 2 = 3
END START 1 + 2 = 3 END START 1 + 2 = 4 END START 1 + 2 = 3 END START 1 + 2 = 3 END
Sample Output Presentation Error Presentation Error Wrong Answer Presentation Error
입 출력, PE, WA, AC 등 몇 가지 상황 을 간단하게 판단 하 는 것 이다.
START 는 입력 을 시 작 했 고 END 는 입력 을 끝 냈 습 니 다.데 이 터 는 이 사이!각 조 에는 2 개의 START 와 END 가 있다.이 두 개 사이 의 데이터 가 PE 인지 WA 인지 AC 인지 판단 하 는 것 이다.
분석: 이 두 개의 비교 할 데 이 터 를 2 문자열 로 각각 저장 하고 줄 을 바 꾸 려 면 문자열 에 추가 해 야 합 니 다.이 두 문자열 이 같 는 지, 같 으 면 AC 입 니 다.같 지 않 습 니 다. PE 인지 WA 인지 판단 하 겠 습 니 다.
import java.util.Scanner;
/** * @author * * 2016-5-26 */
public class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int t = sc.nextInt();
sc.nextLine();
while (t-- > 0) {
String a = "";
String b = "";
while (true) {
String str = sc.nextLine();
if ("END".equals(str)) {
break;
}
if ("START".equals(str)) {
continue;
}
a=a+str;
a=a+"
";
}
while (true) {
String str = sc.nextLine();
if ("END".equals(str)) {
break;
}
if ("START".equals(str)) {
continue;
}
b=b+str;
b=b+"
";
}
int con = 0;// -1--PE,0--WA,1--AC
// System.out.println(a);
// System.out.println(a.length());
// System.out.println(b);
// System.out.println(b.length());
if(a.equals(b)){
con=1;
}else{
con=-1;
String stra="";
for(int i=0;i<a.length();i++){
if(a.charAt(i)==' '||a.charAt(i)=='\t'||a.charAt(i)=='
'){
continue;
}
stra=stra+a.charAt(i);
}
String strb="";
for(int i=0;i<b.length();i++){
if(b.charAt(i)==' '||b.charAt(i)=='\t'||b.charAt(i)=='
'){
continue;
}
strb=strb+b.charAt(i);
}
// System.out.println(stra);
// System.out.println("-------------");
// System.out.println(strb);
if(stra.equals(strb)){
con=-1;
}else{
con=0;
}
}
if(con==0){
System.out.println("Wrong Answer");
}else if(con==-1){
System.out.println("Presentation Error");
}else{
System.out.println("Accepted");
}
}
}
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Is Eclipse IDE dying?In 2014 the Eclipse IDE is the leading development environment for Java with a market share of approximately 65%. but ac...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.