HDOJ 1302 (UVa 573) The Snail (달팽이 가 우물 에 기어 오 르 는 것)
5263 단어 자바
Day Initial Height Distance Climbed Height After Climbing Height After Sliding 1 0 3 3 2 2 2 2.7 4.7 3.7 3 3.7 2.4 6.1 -
Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail’s height will exceed the height of the well or become negative.) You must find out which happens first and on what day.
Input The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative distance. If the fatigue factor drops the snail’s climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.
Output For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.
Sample Input 6 3 1 10 10 2 1 50 50 5 3 14 50 6 4 1 50 6 3 1 1 1 1 1 0 0 0 0
Sample Output success on day 3 failure on day 4 failure on day 7 failure on day 68 success on day 20 failure on day 2
제목: 입력: HGD F, H: 우물 의 높이. U: 낮 에는 달팽이 가 오 를 수 있 는 높이 D: 밤 에는 달팽이 가 내 려 가 는 높이 F: 달팽이 의 피로 계수.; 이곳 의 U 는 처음 입력 한 U 입 니 다. 한 번 만 계산 하면 됩 니 다. 이후 에는 줄 일 때마다 U 에서 reduce 를 빼 면 됩 니 다. 그리고 이곳 의 데 이 터 는 모두 double 형 입 니 다. 낮 에 기어 나 갈 수 있 는 높이 에 따라 달팽이 가 아직 기어 나 가지 않 았 다 면 이때 달팽이 의 낮 기어 다 니 는 속도 가 0 보다 작 으 면 이 달 팽 이 는 기어 나 갈 수 없다 고 판단 할 수 있 습 니 다.출력 은: failure on day * * 달팽이 가 기어 나 오지 못 할 때 달팽이 가 기어 다 니 는 것 을 판단 할 수 있 는 총 일수 입 니 다.
기어 나 갈 수 있다 면 달팽이 가 모두 기어 나 가 는 높이 가 우물 높이 보다 크 면 달 팽 이 는 기어 나 갈 수 있다.
import java.util.Scanner;
public class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
double h = sc.nextDouble();
double u = sc.nextDouble();
double d = sc.nextDouble();
double f = sc.nextDouble();
if(h==0&&u==0&&d==0&&f==0){
return ;
}
double reduce=u*(f/100.0);//
int day = 0;
String str = "success on day ";
double high=0;//
while(high<=h){
day++;
high=high+u;//u
if(high>h){
break;
}
high=high-d;//
if(high<0){// ,
str="failure on day ";
break;
}
u=u-(reduce);//
}
System.out.println(str+day);
}
}
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Is Eclipse IDE dying?In 2014 the Eclipse IDE is the leading development environment for Java with a market share of approximately 65%. but ac...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.