HDOJ 2075 A|B?

1520 단어 자바
Problem Description 정수 A 가 정수 B 에 의 해 정 제 될 수 있 는 지, 왜 xhd 가 이 문 제 를 연구 하 는 지 모 르 겠 으 니 그 를 도와 주세요.
Input 입력 데이터 의 첫 줄 은 T 조 데이터 가 있 음 을 나타 내 는 데이터 T 입 니 다.각 조 의 데 이 터 는 두 개의 정수 A 와 B (A, B < 10 ^ 9) 가 있다.
Output 은 각 그룹의 입력 데이터 에 대해 출력 "YES" 는 정 제 될 수 있 음 을 나타 내 고, "NO" 는 정 제 될 수 없 음 을 나타 낸다.
Sample Input 2 4 2 5 3
Sample Output YES NO
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);

        int n = sc.nextInt();
        while(n-->0){
            int a = sc.nextInt();
            int b = sc.nextInt();
            if(a%b==0){
                System.out.println("YES");

            }else{
                System.out.println("NO");
            }


        }

    }

}

좋은 웹페이지 즐겨찾기