Data Structure - Week 15
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. The distance between any two farms will not exceed 100,000.
Input
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N connectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
Output
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
Sample Output
28
#include <iostream>
using namespace std;
const int SIZE=101;
const int MAX=100000;
int minLen;
int m[SIZE][SIZE]; //
bool s[SIZE]; //
int low[SIZE]; // s
int main(){
int n, last;
cin>>n;
for(int i=1;i<=n;i++){
low[i]=MAX; // low[i]
for(int j=1;j<=n;j++){
cin>>m[i][j];
}
}
s[1]=true; //
last=1;
for(int i=2;i<=n;i++){
int x, tmp=MAX;
for(int i=1;i<=n;i++){ // low[i]
if((!s[i]) && low[i]>m[last][i])
low[i]=m[last][i];
}
for(int i=1;i<=n;i++){ //
if((!s[i]) && tmp>low[i]){
x=i;
tmp=low[i];
}
}
minLen+=tmp;
s[x]=true;
last=x;
}
cout<<minLen<<endl;
return 0;
}
시간 복잡도 분석
수행 시간이 상수인 단계는 "..."로 간략히 기록됩니다.
…
for(int i=1;i<=n;i++){ //n
…
for(int j=1;j<=n;j++){ //n
…
}
}
for(int i=2;i<=n;i++){ //n-1
for(int i=1;i<=n;i++){ //n
…
}
for(int i=1;i<=n;i++){ //n
…
}
}
…
그러므로 시간의 복잡도는 n^2+(n-1)x2n=O(n^2)이다.(이곳에서 사용한 것은 소박한 Prim 알고리즘으로 데이터 구조를 개선할 수 있다. 예를 들어 무더기 최적화를 사용하여 시간의 복잡도를 낮출 수 있다.)
점수: 85 (니마타 피드백은 없고 내가 보고서 양식에 잘못된 점수를 제출했을 수도 있지)
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
우주신과의 교감_1774번황선자씨는 우주신과 교감을 할수 있는 채널러 이다. 하지만 우주신은 하나만 있는 것이 아니기때문에 황선자 씨는 매번 여럿의 우주신과 교감하느라 힘이 든다. 하지만 위대한 우주신들은 바로 황선자씨와 연결될 필요가 없다...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.