C++:클래스 템 플 릿 1(2 개 수의 큰 수)

클래스 템 플 릿 1(2 개 수의 큰 수)
Time Limit(Common/Java):1000MS/3000MS Memory Limit:65536KByte Total Submit:385 Accepted:253
Description
      ,          ,      max()         。 main()   max()              。

아래 의 절 차 를 완전 하 게 기입 하 시 오.
#include <iostream>
using namespace std;

……………………………………
……………………………………
……………………………………
int main()
{
 int a,b;
 double c,d;
 cin>>a>>b>>c>>d;
 Test <int> 
 t1(a,b);
 Test <double>
  t2(c,d);
 cout<<t1.Max()<<endl;
 cout<<t2.Max()<<endl;
 return 0;
}

Input
두 줄 이 있다.첫 번 째 줄 은 두 개의 정수 이 고,두 번 째 행 위 는 두 개의 실수 이다.
Output
두 줄 이 있다.첫 번 째 줄 은 두 정수 중의 대수 이 고,두 번 째 줄 은 두 실수 중의 대수 이다.
Sample Input
4 6 15.89 6.25
Sample Output
6 15.89
코드 블록:
클래스 템 플 릿 으로 만 들 지 않 고 AC 만 할 수 있 습 니 다.
#include <iostream>

using namespace std;

int max(int a ,int b )
{ 

    return a>b?a:b;
}
double max(double a ,double b )
{ 

    return a>b?a:b;
}
 int main()
 { 
    int a,b;
    double x,y; 
   cin>>a>>b;
   cin>>x>>y;
   cout<<max(a,b)<<endl;
   cout<<max(x,y)<<endl;

 return 0;

 }

좋은 웹페이지 즐겨찾기