[백준]#2887 행성 터널
문제
때는 2040년, 이민혁은 우주에 자신만의 왕국을 만들었다. 왕국은 N개의 행성으로 이루어져 있다. 민혁이는 이 행성을 효율적으로 지배하기 위해서 행성을 연결하는 터널을 만들려고 한다.
행성은 3차원 좌표위의 한 점으로 생각하면 된다. 두 행성 A(xA, yA, zA)와 B(xB, yB, zB)를 터널로 연결할 때 드는 비용은 min(|xA-xB|, |yA-yB|, |zA-zB|)이다.
민혁이는 터널을 총 N-1개 건설해서 모든 행성이 서로 연결되게 하려고 한다. 이때, 모든 행성을 터널로 연결하는데 필요한 최소 비용을 구하는 프로그램을 작성하시오.
입력
첫째 줄에 행성의 개수 N이 주어진다. (1 ≤ N ≤ 100,000) 다음 N개 줄에는 각 행성의 x, y, z좌표가 주어진다. 좌표는 -109보다 크거나 같고, 109보다 작거나 같은 정수이다. 한 위치에 행성이 두 개 이상 있는 경우는 없다.
출력
첫째 줄에 모든 행성을 터널로 연결하는데 필요한 최소 비용을 출력한다.
예제 입력 1
5
11 -15 -15
14 -5 -15
-1 -1 -5
10 -4 -1
19 -4 19
예제 출력 1
4
풀이
이 문제는 MST(최소 스패닝 트리) 문제로 크루스칼 알고리즘을 이용해서 풀 수 있었다. 이 문제의 경우 각 X, Y, Z 기준으로 정렬 후에 큐에 넣어주는 방식으로 풀어야 시간, 메모리를 줄일 수 있다.
import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.Arrays;
import java.util.Comparator;
import java.util.PriorityQueue;
public class Main {
static int[] parent;
public static void main(String[] args) throws Exception{
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
int N = Integer.parseInt(br.readLine());
Planet[] planets = new Planet[N];
for(int i=0; i<N; i++) {
String[] input = br.readLine().split(" ");
planets[i] = new Planet(Integer.parseInt(input[0]), Integer.parseInt(input[1]), Integer.parseInt(input[2]), i);
}
PriorityQueue<Pair> pq = new PriorityQueue<>();
parent = new int[N];
for(int i=0; i<N; i++)
parent[i] = i;
Arrays.sort(planets, Comparator.comparingInt(p -> p.x));
for(int i=0; i<N-1; i++) {
Planet p1 = planets[i];
Planet p2 = planets[i+1];
pq.add(new Pair(p1.idx, p2.idx, Math.abs(p1.x-p2.x)));
}
Arrays.sort(planets, Comparator.comparingInt(p -> p.y));
for(int i=0; i<N-1; i++) {
Planet p1 = planets[i];
Planet p2 = planets[i+1];
pq.add(new Pair(p1.idx, p2.idx, Math.abs(p1.y-p2.y)));
}
Arrays.sort(planets, Comparator.comparingInt(p -> p.z));
for(int i=0; i<N-1; i++) {
Planet p1 = planets[i];
Planet p2 = planets[i+1];
pq.add(new Pair(p1.idx, p2.idx, Math.abs(p1.z-p2.z)));
}
int ans = 0;
while(!pq.isEmpty()) {
Pair temp = pq.poll();
int x = temp.x;
int y = temp.y;
if(find(x)==find(y)) continue;
union(x, y);
ans += temp.cost;
}
System.out.println(ans);
}
public static void union(int a, int b) {
a = find(a);
b = find(b);
if(a<b)
parent[b] = a;
else
parent[a] = b;
}
public static int find(int a) {
if(parent[a]==a)
return a;
return parent[a] = find(parent[a]);
}
public static class Planet {
int x;
int y;
int z;
int idx;
public Planet(int x, int y, int z, int idx) {
this.x = x;
this.y = y;
this.z = z;
this.idx = idx;
}
}
public static class Pair implements Comparable<Pair>{
int x;
int y;
int cost;
public Pair(int x, int y, int cost) {
this.x = x;
this.y = y;
this.cost = cost;
}
public int compareTo(Pair p) {
return this.cost > p.cost ? 1 : -1;
}
}
}
Author And Source
이 문제에 관하여([백준]#2887 행성 터널), 우리는 이곳에서 더 많은 자료를 발견하고 링크를 클릭하여 보았다 https://velog.io/@pss407/백준2887-행성-터널저자 귀속: 원작자 정보가 원작자 URL에 포함되어 있으며 저작권은 원작자 소유입니다.
우수한 개발자 콘텐츠 발견에 전념 (Collection and Share based on the CC Protocol.)