항전 OJ1114------------------Piggy-Bank ~ 완전 가방 ~

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X."where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 
Sample Input

   
   
   
   
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4

 
Sample Output

   
   
   
   
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.

이것은 완전한 배낭의 문제이며, 수출하는 것은 가장 작은 상황이다.
그래서 결과수 그룹의 모든 수를 먼저 비교적 큰 값으로 설정한 다음에 첫 번째 값을 0으로 부여한다.min으로 하나하나, 정방향 비교 업데이트
주요 단계:
for i=1..N
        f[v]=max{f[v],f[v-c[i]]+w[i]}

가장 작은 상황이 필요하기 때문에 MAX를 MIN으로 바꿉니다.
IMPOSSIBLE의 경우 마지막 그룹의 마지막 값이 업데이트되지 않았기 때문에 판단하고 IMPOSSIBLE을 출력하면 됩니다. 여기서 int_를 사용할 수 없습니다.max, 이 수를 더하면 경계를 넘어 마이너스가 되기 때문에 일련의 비교 오류가 발생합니다!
코드:
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

int main()
{
	int T;	cin>>T;
	const int INF = 1000000001;
	while(T--)
	{
		int E,F,N;
		cin>>E>>F>>N;
		vector<int>P(N+1);
		vector<int>W(N+1);
		vector<int>f(F-E+1,INF);
		f[0]=0;
		for(int i=1;i<=N;i++)
			cin>>P[i]>>W[i];
		for(int i=1;i<=N;i++)
			for(int v=W[i];v<=F-E;v++)
				f[v]=min(f[v],f[v-W[i]]+P[i]);
		if(f[F-E]==INF)
			cout<<"This is impossible."<<endl;
		else
			cout<<"The minimum amount of money in the piggy-bank is "<<f[F-E]<<"."<<endl;
	}
	return 0;
}

좋은 웹페이지 즐겨찾기