02 - 선형 구조 4 Pop Sequence (python 3)

2511 단어 데이터 구조

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO

제목 해석: K 줄, M 개 수 를 주 고 1 - M 의 질서 있 는 수열 로 N 크기 의 스 택 에서 주어진 순서 로 출력 합 니 다. 
프로그램 세그먼트: 이 문 제 는 비교적 간단 합 니 다. list 의 append 와 pop 를 활용 하면 됩 니 다.
MNK=list(map(int,input().split()))
M=MNK[0]
N=MNK[1]
K=MNK[2]
L=[]
for i in range (K):
    L.append(list(map(int,input().split())))
  

lpop=[]
for i in range(N):
    lpop.append(i+1)
for i in  range(K):
    lstack=[]
    lsample=L[i]
    #print("the"+str(i)+"list:")
    for i in range(N):
        lstack.append(lpop[i])
        if len(lstack)>M:
            print("NO")
            break
        else:
            
            while(lstack[-1]==lsample[0]):
                lstack.pop()
                lsample.pop(0)
                if(len(lstack)==0):
                    break
        #print('lstack:'+str(lstack))
        #print('lsample:'+str(lsample))
    if(len(lsample)==0):
        print("YES")
    else:
        if len(lstack)>M:
            None
        else:
            print("NO")

결실
테스트 포인트
제시 하 다.
결실
시간 을 소모 하 다
메모리
0
sample 난 서, 일반적인 Y & N
정 답
22 ms
3216 KB
1
최대 사이즈 달성 후 넘 침
정 답
22 ms
3188 KB
2
M==N
정 답
22 ms
3188 KB
3
최대 수
정 답
25 ms
3308 KB
4
최 소수
정 답
22 ms
3256 KB
5
카드 특수 오류 알고리즘 (크기 비교 로 판단)
정 답
22 ms
3228 KB

좋은 웹페이지 즐겨찾기