UVA 12293 Box Game
Box Game
There are two identical boxes. One of them contains n balls, while the other box contains one ball. Alice and Bob invented a game with the boxes and balls, which is played as follows:
Alice and Bob moves alternatively, Alice moves first. For each move, the player finds out the box having fewer number of balls inside, and empties that box (the balls inside will be removed forever), and redistribute the balls in the other box. After the redistribution, each box should contain at least one ball. If a player cannot perform a valid move, he loses. A typical game is shown below:
When both boxes contain only one ball, Bob cannot do anything more, so Alice wins.
Question: if Alice and Bob are both clever enough, who will win? Suppose both of them are very smart and always follows a perfect strategy.
Input
There will be at most 300 test cases. Each test case contains an integer
n (
2n109) in a single line. The input terminates by
n = 0.
Output
For each test case, print a single line, the name of the winner.
Sample Input
2
3
4
0
Sample Output
Alice
Bob
Alice
The Seventh Hunan Collegiate Programming Contest Problemsetter: Rujia Liu, Special Thanks: Yiming Li & Jane Alam Jan
이 문제는 처음에 하나의 수와 하나의 1이 있다는 뜻이다. 앨리스는 두 가지 중 비교적 작은 것을 버리고 비교적 큰 것을 다시 두 개의 수로 나누고 BOB는 앨리스의 조작을 반복한다.두 사람이 번갈아 가며 조작하면 누가 마지막으로 조작해야 하는 수가 (1,1)이면 진다. 출력 위너!#include<cstdio>
int main()
{
int num;
while(scanf("%u",&num),num)
{
if(((num+1)&num)==0)puts("Bob");
else puts("Alice");
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
application ---- enter and save the file code
Input file name and content - input_content.html
Receive content and save file and content - input_content01.jsp...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.
2
3
4
0
Alice
Bob
Alice
#include<cstdio>
int main()
{
int num;
while(scanf("%u",&num),num)
{
if(((num+1)&num)==0)puts("Bob");
else puts("Alice");
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
application ---- enter and save the file codeInput file name and content - input_content.html Receive content and save file and content - input_content01.jsp...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.