soj1564. HOUSING
4317 단어 in
1564. HOUSING
Constraints
Time Limit: 1 secs, Memory Limit: 32 MB
Description
For the Youth Olympic Games in Singapore, the administration is considering to house each team in several units with at least 5 people per unit. A team can have from 5 to 100 members, depending on the sport they do. For example, if there are 16 team members, there are 6 ways to distribute the team members into units: (1) one unit with 16 team members; (2) two units with 5 and 11 team members, respectively; (3) two units with 6 and 10 team members, respectively; (4) two units with 7 and 9 team members, respectively; (5) two units with 8 team members each; (6) two units with 5 team members each plus a third unit with 6 team members. This list might become quite lengthy for a large team size.
In order to see how many choices to distribute the team members there are, the administration would like to have a computer program that computes for a number n the number m(n) of possible ways to distribute the team members into the units allocated, with at least 5 people per unit. Note that equivalent distributions like 5 + 5 + 6, 5 + 6 + 5 and 6 + 5 + 5 are counted only once. So m(16) = 6 (as seen above), m(17) = 7 (namely 17, 5 + 12, 6 + 11, 7 + 10, 8 + 9, 5 + 5 + 7, 5 + 6 + 6) and m(20) = 13.The computer program should read the number n and compute m(n).
Input
The input contains just one number which is the number n as described above, where 5 <= n <= 100.
Output
The output consists of a single line with an integer that is the number m(n) as specified above. As n is at most 100, one can estimate that m(n) has at most 7 decimal digits.
Sample Input 20
Sample Output 13
거스름돈을 바꾸는 동적 계획과 차이가 많지 않지만, 이곳의 동전 수는 5-n이기 때문에 바꾸면 된다.#include <iostream>
#include <memory.h>
using namespace std;
long long f[110];
int main()
{
int n;
while(cin >> n)
{
memset(f,0,sizeof(f));
int i;
f[0] = 1;
int j;
for(i = 5;i <= n;i++)
{
for(j = i;j <= n;j++)
f[j] += f[j-i];
}
cout << f[n] << endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Chapter 12. 딕셔너리(Dictionary)
딕셔너리는 { ...
} 으로 감싸서 표현하고
안은 이렇게 생겼다.
리스트는 키가 될 수 없다.
중복될 수 없다.
중복되도 상관없다.
아무거나 와도 상관없다.
인덱스 대신 키 값을 넣고 그 키가 열쇠가 되어 그에 해...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.
Time Limit: 1 secs, Memory Limit: 32 MB
Description
For the Youth Olympic Games in Singapore, the administration is considering to house each team in several units with at least 5 people per unit. A team can have from 5 to 100 members, depending on the sport they do. For example, if there are 16 team members, there are 6 ways to distribute the team members into units: (1) one unit with 16 team members; (2) two units with 5 and 11 team members, respectively; (3) two units with 6 and 10 team members, respectively; (4) two units with 7 and 9 team members, respectively; (5) two units with 8 team members each; (6) two units with 5 team members each plus a third unit with 6 team members. This list might become quite lengthy for a large team size.
In order to see how many choices to distribute the team members there are, the administration would like to have a computer program that computes for a number n the number m(n) of possible ways to distribute the team members into the units allocated, with at least 5 people per unit. Note that equivalent distributions like 5 + 5 + 6, 5 + 6 + 5 and 6 + 5 + 5 are counted only once. So m(16) = 6 (as seen above), m(17) = 7 (namely 17, 5 + 12, 6 + 11, 7 + 10, 8 + 9, 5 + 5 + 7, 5 + 6 + 6) and m(20) = 13.The computer program should read the number n and compute m(n).
Input
The input contains just one number which is the number n as described above, where 5 <= n <= 100.
Output
The output consists of a single line with an integer that is the number m(n) as specified above. As n is at most 100, one can estimate that m(n) has at most 7 decimal digits.
Sample Input 20
Sample Output 13
거스름돈을 바꾸는 동적 계획과 차이가 많지 않지만, 이곳의 동전 수는 5-n이기 때문에 바꾸면 된다.#include <iostream>
#include <memory.h>
using namespace std;
long long f[110];
int main()
{
int n;
while(cin >> n)
{
memset(f,0,sizeof(f));
int i;
f[0] = 1;
int j;
for(i = 5;i <= n;i++)
{
for(j = i;j <= n;j++)
f[j] += f[j-i];
}
cout << f[n] << endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Chapter 12. 딕셔너리(Dictionary)
딕셔너리는 { ...
} 으로 감싸서 표현하고
안은 이렇게 생겼다.
리스트는 키가 될 수 없다.
중복될 수 없다.
중복되도 상관없다.
아무거나 와도 상관없다.
인덱스 대신 키 값을 넣고 그 키가 열쇠가 되어 그에 해...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.
The input contains just one number which is the number n as described above, where 5 <= n <= 100.
Output
The output consists of a single line with an integer that is the number m(n) as specified above. As n is at most 100, one can estimate that m(n) has at most 7 decimal digits.
Sample Input 20
Sample Output 13
거스름돈을 바꾸는 동적 계획과 차이가 많지 않지만, 이곳의 동전 수는 5-n이기 때문에 바꾸면 된다.#include <iostream>
#include <memory.h>
using namespace std;
long long f[110];
int main()
{
int n;
while(cin >> n)
{
memset(f,0,sizeof(f));
int i;
f[0] = 1;
int j;
for(i = 5;i <= n;i++)
{
for(j = i;j <= n;j++)
f[j] += f[j-i];
}
cout << f[n] << endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Chapter 12. 딕셔너리(Dictionary)
딕셔너리는 { ...
} 으로 감싸서 표현하고
안은 이렇게 생겼다.
리스트는 키가 될 수 없다.
중복될 수 없다.
중복되도 상관없다.
아무거나 와도 상관없다.
인덱스 대신 키 값을 넣고 그 키가 열쇠가 되어 그에 해...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.
20
Sample Output 13
거스름돈을 바꾸는 동적 계획과 차이가 많지 않지만, 이곳의 동전 수는 5-n이기 때문에 바꾸면 된다.#include <iostream>
#include <memory.h>
using namespace std;
long long f[110];
int main()
{
int n;
while(cin >> n)
{
memset(f,0,sizeof(f));
int i;
f[0] = 1;
int j;
for(i = 5;i <= n;i++)
{
for(j = i;j <= n;j++)
f[j] += f[j-i];
}
cout << f[n] << endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Chapter 12. 딕셔너리(Dictionary)
딕셔너리는 { ...
} 으로 감싸서 표현하고
안은 이렇게 생겼다.
리스트는 키가 될 수 없다.
중복될 수 없다.
중복되도 상관없다.
아무거나 와도 상관없다.
인덱스 대신 키 값을 넣고 그 키가 열쇠가 되어 그에 해...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.
13
#include <iostream>
#include <memory.h>
using namespace std;
long long f[110];
int main()
{
int n;
while(cin >> n)
{
memset(f,0,sizeof(f));
int i;
f[0] = 1;
int j;
for(i = 5;i <= n;i++)
{
for(j = i;j <= n;j++)
f[j] += f[j-i];
}
cout << f[n] << endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Chapter 12. 딕셔너리(Dictionary)딕셔너리는 { ... } 으로 감싸서 표현하고 안은 이렇게 생겼다. 리스트는 키가 될 수 없다. 중복될 수 없다. 중복되도 상관없다. 아무거나 와도 상관없다. 인덱스 대신 키 값을 넣고 그 키가 열쇠가 되어 그에 해...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.