poj 3252 Round Numbers(디지털 DP, 레벨 4)

2790 단어
Round Numbers
Time Limit: 2000MS
 
Memory Limit: 65536K
Total Submissions: 7481
 
Accepted: 2562
Description
The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.
They have thus resorted to "round number"matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins, otherwise the second cow wins.
A positive integer N is said to be a "round number"if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.
Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers"are in a given range.
Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).
Input
Line 1: Two space-separated integers, respectively 
Start and 
Finish.
Output
Line 1: A single integer that is the count of round numbers in the inclusive range 
Start..
Finish
Sample Input
2 12

Sample Output
6

Source
USACO 2006 November Silver
물 디지털 DP
#include<cstdio>
#include<cstring>
#include<iostream>
#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define clr(f,z) memset(f,z,sizeof(f))
#define LL __int64
using namespace std;
int dp[40][40][40];//  ,1,0
int bit[40],pos;
int DP(int pp,int one,int zero,bool nozero,bool big)
{
  if(pp==0)return zero>=one;
  if(big&&dp[pp][one][zero]!=-1)return dp[pp][one][zero];
  int kn=big?1:bit[pp];
  int ret=0;
  FOR(i,0,kn)
  {                     ///    0    
    ret+=DP(pp-1,one+(i==1),zero+(nozero&&i==0),nozero||i!=0,big||kn!=i);
  }
  if(big)dp[pp][one][zero]=ret;
  return ret;
}
int get(int x)
{
  pos=0;
  while(x)
  {
    bit[++pos]=x&1;x/=2;
  }
  clr(dp,-1);
  return DP(pos,0,0,0,0);
}
int main()
{
  int n,m;
  while(cin>>n>>m)
  { if(n==0&&m==0)break;
    cout<<get(m)-get(n-1)<<endl;
  }
}

좋은 웹페이지 즐겨찾기