poj2406 문제 풀이 보고서

Power Strings
Time Limit: 3000MS
 
Memory Limit: 65536K
Total Submissions: 13765
 
Accepted: 5738
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc"and b = "def"then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = ""(the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3
 : 
#include<iostream>
using namespace std;
char str[1000010];
int main()
{
	int i,j,k,len;
	while(scanf("%s",&str[1])&&strcmp(".",&str[1]))
	{
		len=strlen(&str[1]);
		for(i=1;i<=len;i++)
		{
			if(len%i==0)
			{
				for(j=1;j<=(len-i)/i;j++)
				{
					for(k=1;k<=i;k++)
					{
						if(str[k]!=str[j*i+k])
							goto end;
					}

				}
				cout<<len/i<<endl;
				goto exit;
			}
end:		i=i;
		}
exit:		i=i;
	}


	return 0;
}  

좋은 웹페이지 즐겨찾기