POJ_2236(병렬 검색 집합)
Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p"(1 <= p <= N), which means repairing computer p.
2. "S p q"(1 <= p, q <= N), which means testing whether computer p and q can communicate.
The input will not exceed 300000 lines.
Output
For each Testing operation, print "SUCCESS"if the two computers can communicate, or "FAIL"if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
AC :
#include"stdio.h"
#include "math.h"
const int MAX_SIZE = 1002;
class UFS
{
public:
int ancestor[MAX_SIZE];
int degree[MAX_SIZE];
bool repaired[MAX_SIZE];
int xi[MAX_SIZE];
int yi[MAX_SIZE];
void MakeSet();
int FindSet(const int& x);
void Union(const int& x,const int& y);
};
void UFS::MakeSet()
{
for(int i = 0;i<MAX_SIZE;++i)
{
this->ancestor[i] = i;
this->degree[i] = 0;
this->repaired[i] = false;
this->xi[i] = 0;
this->yi[i] = 0;
}
}
int UFS::FindSet(const int& x)
{
if(ancestor[x] != x)
{
ancestor[x] = FindSet(ancestor[x]);
}
return ancestor[x];
}
void UFS::Union(const int& x,const int& y)
{
int xAncestor = this->FindSet(x);
int yAncestor = this->FindSet(y);
if(xAncestor == yAncestor)
{
return ;
}
if(degree[xAncestor] < degree[yAncestor])
{
ancestor[xAncestor] = yAncestor;
}
else
{
if(degree[xAncestor] == degree[yAncestor])
{
degree[xAncestor] += 1;
}
ancestor[yAncestor] = xAncestor;
}
}
int N,d;
int main(void)
{
UFS ufs;
ufs.MakeSet();
scanf("%d %d",&N,&d);
for(int i = 1;i<=N;++i)
{
scanf("%d %d",&ufs.xi[i],&ufs.yi[i]);
}
char c;
int c1,c2;
while(scanf("%c",&c)!=EOF)
{
if(c == 'O')
{
scanf(" %d",&c1);
ufs.repaired[c1] = true;
for(int j = 1;j<=N;j++)
{
if(ufs.repaired[j] == true)
{
if(pow(ufs.xi[c1]-ufs.xi[j],2) + pow(ufs.yi[c1]-ufs.yi[j],2)<= d*d)
{
ufs.Union(c1,j);
}
}
}
}
if(c == 'S')
{
scanf(" %d %d",&c1,&c2);
if(ufs.FindSet(c1) == ufs.FindSet(c2))
{
printf("SUCCESS/n");
}
else
{
printf("FAIL/n");
}
}
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
application ---- enter and save the file codeInput file name and content - input_content.html Receive content and save file and content - input_content01.jsp...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.