POJ-1032

Parliament
Time Limit: 1000MS
 
Memory Limit: 10000K
Total Submissions: 14371
 
Accepted: 6035
Description
New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished. 
You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible. 
Input
The input file contains a single integer N (5<=N<=1000 ).
Output
Write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces.
Sample Input
7

Sample Output
3 4

Source
Northeastern Europe 1998
#include <stdio.h>

int groups[50];

int main()
{
    int i, j, num;
    
    scanf("%d", &num);
    for (i = 0; num; i++) {
        if (num-i-2 >= 0) {
           num -= i+2;
           groups[i] = i+2;
        }else {
              for (j = --i; num; j--) {
                  if (j < 0)
                     j = i;
                  groups[j]++;
                  num--;
              }
        }
    }
    for (i = 0; groups[i]; i++)
        printf("%d ", groups[i]); 
    return 0;
} 

좋은 웹페이지 즐겨찾기